Clobbered SDA1 Wn Partition Map After Running Install

As the subject says, my Win boot partition somehow got clobbered during the OpenSUSE install. I tried the install twice, with the same results. I had had one successful install prior to this, but had to remove the system due to a size constraing I had at the time.

In the meantime, between Hirens Boot cd, and the Windows 7 repair facility, I managed to get the first partition to boot again. The first time I clobbered it, I wound up having to reinstall Win 7 again! What a nuisance.

The upshot of the situation now is that I’ve lost the Grub loader, and need to reinstall it without going through any Linux install or repair. I need to boot into OpenSUSE without a loader and somehow rewrite Grub.

Is there a way to accomplish this? I’m sure there is, but I don’t want to clobber that partition map again. I didn’t do it in the first place, and don’t understand why this happened. The partitions that OpenSUSE got installed on were already in existence. I’m assuming the bootloader install did the job. Don’t know.


Re-Install Grub Quickly with Parted Magic

Be sure to get the parted magic linked in the guide

If you get stuck - ask

Good stuff. Off to the races now if I can keep my eyes open. All day fiddling with windows has me seeing double!:0

Will post results.

I’m assuming some understanding on your part
You didn’t post any disk info
Grub can get complicated
Here is a guide to running win and suse
Install openSUSE alongside Win7/Vista - A Guide
It may help you understand some things

Oh, I’ve worked with Unix and Linux for quite some years. Linux was just getting a GUI developed for it the last time I had it installed.

The thing that throws me is that I had no problem with installation side by side, the first time I ran it. Both os’ were booting without incident. The distro disc that I had made was the same. I followed the same procedure, basically automated config. The partition map hadn’t changed.

Oh well. Some of the greatest questions in life go unanswered:)


Well, after a little break, I created and booted up from the Parted Magic live cd. I think it took me all of 2 minutes to get Grub reinstalled properly and working with all systems installed.

Man, what a difference from having to manually edit files like the FSTAB, as I was doing years ago to get things to work properly!

Thank you for your help.

Good to hear
Happy to help