Clipboard not accepting special characters (german umlauts).

Hi all.

I had a fresh installation of Leap 15.3 recently with Russian as system language. Then I have changed that to German via Yast (as a system language) and have an issue in that Clipboard is not accepting special characters (German umlauts), it’s showing instead some question marks if at all - in the Clipper Applet I have an empty line sometimes. In the LibreOffice Writer I can, however, copy/paste without problems within one document.

How can I debug that, please?

Thanks in advance,

Can we assume KDE/Plasma?

Yes, sorry, have had to mention.

Just to gather some information (I have no idea what is wrong).

You, as system manager, changes the system language from Russian into German (usi ng YaST).

Then a user (probably also you in a different role). complains that characters outside the ASCII range are not stored correct in the clipboard. Now that user uses KDE and that user has of course his own language settings done in KDE. Are they also changed? Are they Russian, German, or different?

Yes, all correct.
That new user has a German as the language in KDE control center + German locale as default.


By the way, which is the correct name for Clipboard widget: Clipper, Klipper, Clipboard or what? I can not find that in Software Management in Yast…

Somebody, please, any ideas?



It doesn’t work only in LibreOffice, Kate works, browsers are working.


Two things to do –

  1. Within the KDE Plasma System Settings → section “Personalization” → section “Regional Settings” – set to “Language” and “Formats” to “Germany – German”.
  2. Check that the package “plasma5-workspace-lang” is installed – the package which installs ‘/usr/bin/klipper’ is “plasma5-workspace” …


I have had en_DE in Formats…
After that I have reinstalled plasma5-workspace, and, voala, Klipper works.



Et voilà !