Client Config for Samba/LDAP Domain

Currently running Samba-LDAP PDC. Windows clients can log in and access network shares without being password challenged. Linux clients can log in to the domain as well and their desktop/home folder is loaded from the pdc. However the linux client must enter password to access samba shares. I believe that ldap is supposed fix this as it is a Single Sign on issue… howver I can’t configure this suse client to be able to access samba shares without a password and a valid domain user logged on. Can anyone help me get this configured?

I am having the same problem, did you find the answer to the problem?

The windows machines can access to the samba shares without the need to enter a password but the Linux PC are promted for a password, even if they are part of the domain.

I am using a PDC Samba + LDAP + WINS + DHCP server.

This is the smb.conf file of the Linux client, I used the yast domain membership wizard to setup the connection.

[global]

workgroup = DOMAIN
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
usershare allow guests = No
idmap gid = 10000-20000
idmap uid = 10000-20000
security = domain
template shell = /bin/bash
winbind offline logon = yes

[homes]

comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[profiles]

comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]

comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]

comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]

comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]

comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775