clicking on some links opens two tabs in firefox

I’m experiencing a strange behaviour.

When I click a link on some programas (but not all of them) ff open the link in a new window with two identical tabs.
It happens when using ferdi or when my system loads the nextcloud client and it can’t establish a connection and ask for persmission opening a window in ff, or whn clicking a link in libreoffice, but it does not happen when I click a link if thunderbird or in whatsapp web inside ff.

I have disabled all addons in ff and still the same.

What can be causing that?

best regards

I can’t tell. Just an idea for trouble shooting: Try right click and then open in new window or open in new tab. Same result? If yes, it might at least rule out any mouse / input issues. Otherwise, maybe you better explain again more detailed what you are doing what is the result. And others who can help better than I can may need to know what version of FF and DE you are using.

It is not any mouse issue at all. I have a program (nextcloud client) which starts when I start mi session in plasma (I launch it from system settings-start and shutdown) and when it has any trouble connecting to the server it opens a ff window to ask for permission… and it opens it with two identical tabs, same when I click on a link in a document of OO writer or a link in ferdi and some other programs, but not from thunderbird (91.9.0)
If I right click from ff on a link and open new tab or new window it works ok.
I have ff 100.01 (but ff has upgraded some times since that is happenning) and plasma 5.18.

best regards

Ah, OK. It’s not when you click on a link inside FF but only from external source, if I got it right. Just tried to reproduce this, but I can’t. FF 100.0 just now updating. Sorry, I’m not sure if I can help. Only, as this does not happen in Thunderbird it may be related to something about Plasma or it’s interface to Mozilla.

Edit: Plasma 5.18.6

FWIW, if you go to system settings => applications => default application => webbrowser => open URLs in…

Anything strange? Here it is …in the following application: Firefox.

Updated to FF 100.02 - still can’t reproduce it.

with the following command: /usr/bin/firefox %u

In “in the following application” firefox does not appear, just opera, chromium and seamonkey.
if I set one of them then the links open just once instead of twice

ups! it was the %u in

/usr/bin/firefox %u

setting it to


and it works normal way.


Welcome! :wink: