clicking on .odt or .doc file doesn't launch libreoffice

I upgraded yesterday libreoffice to 3.6.
Since then, when I click on a .odt, .doc, etc file in dolphin, instead of launching libreoffice and open the file, dolphin opens it as an archive.
If I uncheck in dolphin settings -> Navigation the option “Open archives as folders” the file is opened with libreoffice normally, but then I cannot open a .zip as a folder in dolphin.
Any idea about how to make it work as before? (with “Open archives as folders” checked clicking on a .odt launchs libreoffice).

(Sorry for my english. I’m not sure whether what I wrote is understandable)

On 12/06/2012 10:26 AM, wrbbt wrote:
> I upgraded yesterday libreoffice to 3.6.
> Since then, when I click on a .odt, .doc, etc file in dolphin, instead
> of launching libreoffice and open the file, dolphin opens it as an
> archive.

then i’d guess you upgraded your LibreOffice incorrectly…

how did you upgrade? (that is, did you use YaST? or a one click at
http://software.opensuse.org/search? did you download rpms off the
internet (from where?) and manually run rpm commands in a terminal (as a
user or as root)? did you download source files and compile locally?
did you follow a guide, LO documentation, or etc? if so please give us a
URL to the guide, documentation, etc.

or did you use some other method–please describe, as that will be the
only way to try to spot what you did wrong…)

additionally, we need to know:
what operating system and version are you running?
what desktop environment and version?

and finally, are any of these helpful: http://tinyurl.com/bw2sdzl

and, just as a matter of my curiosity: what was the new feature or
capability that drove you to need (or want) to upgrade from your
previous version of LibreOffice (and what version was that abandoned
version?)


dd http://tinyurl.com/DD-Caveat

Thank you very much for your concern and your help.

I’m running opensuse 12.1 and kde 4.9.4
I upgraded using the libreoffice stable repo. I just did zypper up
Here you have my repos. If you find something that shouldn’t be there, please tell me.

 zypper lr -u
#  | Alias         | Name               | Enabled | Refresh | URI                                                                               
---+---------------+--------------------+---------+---------+----------------------------------------------------------------------------------
 1 | KDE_4.9       | KDE 4.9            | Yes     | Yes     |  http://download.opensuse.org/repositories/KDE:/Release:/49/openSUSE_12.1/         
 2 | KDE_Extra     | KDE Extra          | Yes     | Yes     |  http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_49_openSUSE_12.1
 3 | Kernel:stable | Kernel:stable      | Yes     | Yes     |  http://download.opensuse.org/repositories/Kernel:/stable/standard/                           
 4 | libdvdcss     | libdvdcss          | Yes     | Yes     |  http://opensuse-guide.org/repo/12.1                                               
 5 | libreoffice   | libreoffice        | Yes     | Yes     |  http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.1       
6 | non-oss       | non-oss            | Yes     | Yes     |  http://download.opensuse.org/distribution/12.1/repo/non-oss/                      
7 | oss           | oss                | Yes     | Yes     |  http://download.opensuse.org/distribution/12.1/repo/oss/                          
8 | packman-ess   | packman-essentials | Yes     | Yes     |  http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_12.1/Essentials           
9 | packman-mult  | packman-multimedia | Yes     | Yes     |  http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_12.1/Multimedia           
10 | update        | updates            | Yes     | Yes     | http://download.opensuse.org/update/12.1/ 

To answer your curiosity, I was interested in some of the new features of libreoffice 3.6. Certainly, it was not a question of life or death, so I waited for some months, till 3.6 appeared in the stable repo; then I upgraded.

I have to say also that doing “zypper up” I updated many other things. I guess the problem is not in libreoffice but in dolphin. In fact, libreoffice seems to work normally. Even, if I click on the same odt files in the Quick access widget, it opens in libreoffice normally; in konqueror odt and doc files launch LO, docx files get open as archives. The problem seems to be in dolphin and partially in konqueror.

If you need to know more things, just ask. Thanks again.

A bit of a rethorical question: why oh why do people never tell waht tehy use in their fiosrst post??? We always first have toa sk the obvious, spoiling time and energy >:)

That said, in KDE the file name associations are configured using Desktop Settinmgs > File name associations (or similar wording). Did you check there?

Just adding the repo, and running zypper up is not the way to go. Start the softwaremanager, select View - Repos, select the LibreOffice repo, and click “Switch system packages …” on the top of the column on the right. AFAICS you now have a mix of LO packages from distribution repo and LO repo.

Just a rethorical answer to a rethorical question.:wink:
Sorry. I always am in doubt of providing too much information for something that could be well known and very easy. But I’ll try to do better next time. I understand your situation needing to make an effort to help people that make it difficult to be helped. Sorry again.

I did of course. Everything fine.

Thanks anyway.

How could we know which of the supported (many even come here using unsupported) version of openSUSE you use? Or which DE (there are many).
But forget it, as you say, trying to help is often frustrating and it happened to be you where my frustration landed. Sorry for it.

Fine, I hope tha incluse checking by using the Change button whit LibreOddice Wrire selected to see if the correct program (writer in my case) is called.

In any case, what Knurpht says seems to be the first thing to do. Doing a zypper up (update all packages to their newest versions without changing the vendor), while in this case you need a zypper dup --repo … to change a consistent bunch of packages to those from a certain repo can create havoc of course.

Using YaST, as Knurpht says, seems to be the most easy way.

On 2012-12-06 13:36, wrbbt wrote:
> hcvv;2508905 Wrote:
>> > That said, in KDE the file name associations are configured using
>> > Desktop Settinmgs > File name associations (or similar wording). Did
>> > you check there?
> I did of course. Everything fine.

I think that one of the updates changed the associations. The LO files
are in fact archives, they might be opened as such instead. If the
association to LO disappears, or if the file manager looks at the
apparent contents instead of the extension, you get that effect, I think.

Verifying that you are not getting packages from mixed repos is
something you should do.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Which spell-checker? :smiley:

On 12/06/2012 12:06 PM, wrbbt wrote:
>
> zypper lr -u
> # | Alias | Name | Enabled | Refresh
> —±--------------±-------------------±--------±-------
> 1 | KDE_4.9 | KDE 4.9 | Yes | Yes
> 2 | KDE_Extra | KDE Extra | Yes | Yes
> 3 | Kernel:stable | Kernel:stable | Yes | Yes
> 4 | libdvdcss | libdvdcss | Yes | Yes
> 5 | libreoffice | libreoffice | Yes | Yes
> 6 | non-oss | non-oss | Yes | Yes
> 7 | oss | oss | Yes | Yes
> 8 | packman-ess | packman-essentials | Yes | Yes
> 9 | packman-mult | packman-multimedia | Yes | Yes
> 10 | update | updates | Yes | Yes

ok, to that above…that is, it IS your machine and you may certainly
do with it as you wish, but i recommend to all folks who don’t follow
the advice in the paragraph beginning with IMPORTANT in this post
http://tinyurl.com/33qc9vu to change their ways and follow that very
sound advice…

i say that because by not following that advice you have introduced
instabilities that you are unprepared to solve…

now, others here may know exactly where this strangeness comes from, i
do not–you might TRY looking in Personal Settings - Configure Desktop >
Common Appearance and Behavior > File Associations and then try to
re-associate each file type with the appropriate application…

and, keep checking here because eventually someone else with exactly the
same software mix, and problem symptoms may show up…and, if so then it
probably is a bug somewhere that needs be filed…

in fact, some here might urge you to file a bug now…and, maybe you
should…i do not know…

OH! if you use YaST > Security and Users > User and Group Management to
temporarily add a new TestUser, then log out and log back in as the
TestUser, is the problem resolved?


dd http://tinyurl.com/DD-Caveat

Don’t worry. I’m very grateful for the help I’ve always got in this forum.

I’ve done it that way and it’s still the same. In konqueror everything is fine except for .docx. In dolphin only if the option “Open archives as folders” in the settings is unchecked.

Anyway. I can survive. Thanks again.

I’ve done again the associations. Still the same.

How do I verify that?
I have used the button in Yast to switch to the packages in the same repo. Is that enough or should I do some other verification?

Thanks

I knew that post which helped me a lot a couple of years ago. Later I added some other repos but I think the situation is (or was) under control.

Thanks for your concern.

On 12/06/2012 06:36 AM, hcvv pecked at the keyboard and wrote:
> A bit of a rethorical question: why oh why do people never tell waht
> tehy use in their fiosrst post??? We always first have toa sk the
> obvious, spoiling time and energy >:)
>
> That said, in KDE the file name associations are configured using
> Desktop Settinmgs > File name associations (or similar wording). Did you
> check there?
>
>
And why oh why do people NOT spell check before sending their post?

On 12/06/2012 08:06 PM, Ken Schneider wrote:
> And why oh why do people NOT spell check before sending their post?

beecause it makes no deffirence…as long as et communicatees…


dd

lol! I guess you were jerking…

Sure no difference?

On 2012-12-06 17:06, wrbbt wrote:

> How do I verify that?
> I have used the button in Yast to switch to the packages in the same
> repo. Is that enough or should I do some other verification?

I do it manually.

I fire up the yast package manager, QT flavour. I select the filter by
repository, and then I view package by package, with the version tab
selected; I watch which version is installed. This is tedious, but it is
the most precise way.

This would be easier if the column list in yast would be more customizable.

Another method is to make a customized rpm query. For example, I use these:


rpm -q -a --queryformat "%{INSTALLTIME};%{INSTALLTIME:day}; \
%{BUILDTIME:day}; %{NAME};%{VERSION}-%-7{RELEASE};%{arch}; \
%{VENDOR};%{PACKAGER};%{DISTRIBUTION};%{DISTTAG}
" \
| sort | cut --fields="2-" --delimiter=\; \
| tee rpmlist.csv | less -S

or

rpm -q -a --queryformat "%{INSTALLTIME}	%{INSTALLTIME:day} \
%{BUILDTIME:day} %-30{NAME}	%15{VERSION}-%-7{RELEASE}	%{arch} \
%25{VENDOR}%25{PACKAGER} == %{DISTRIBUTION} %{DISTTAG}
" \
| sort | cut --fields="2-" > rpmlist




Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Now it works normally.
I don’t know which solution did it, because I applied some. But finally everything seems to be in place.
Thanks to everybody.
This forum is really great!

Maybe it was on, but not in Shakespeare mode.

It was helpful anyway.
The post, not the spellchecker, really.