Clicking internet links doesn't work

For many months now, whenever I’ve tried to follow a link, say, from an email, firefox opens but it tries to open a file which has been created in ~/.cache/kioexec/krun/… After months of looking for ways to fix it I still can’t make it work as it should. I have a workaround which is to copy the link address, open firefox and paste the link into the url bar.
Does anyone know what my problem is and how to fix it?
I’m totally up-to-date with tumbleweed and as you can see my default browser is firefox (currently 91.0.1).

And your Desktop???

I couldn’t tell for sure.

However, that’s not the firefox cache. Did you search in about:config? I’d try searching for that path or parts of it like “kio” or “krun”. You’d have to show all settings and use “ctrl+f” not the search bar for setting names. In settings names you can search for “link” or “browser.link” - anything suspiscious?
It could also be some some glitch in MIME settings?

Sorry I thought the kio bit was a pointer. The desktop is the latest kde framework-5.85 and plasma 5.22.

Can you try on the command line “xdg-open https://forums.opensuse.org”. Does that work, if not please post the command on the complete output in this topic.

For KDE you should be able to fix this through Settings → System Settings → Applications.

The following all appears from just the original command. It looks as though I’ve made 2 separate commands which I haven’t!:

peteh ~ > xdg-open https://forums.opensuse.org
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'"
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"
peteh ~ > command= "/usr/bin/firefox" args= ("/usr/bin/firefox", "https://forums.opensuse.org")
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'"
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"
kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job.
Copying QUrl("https://forums.opensuse.org")  to QUrl("file:///home/peteh/.cache/kioexec/krun/7198_0/unnamed")
telling kioexecd to watch path "/home/peteh/.cache/kioexec/krun/7198_0/unnamed" dest "https://forums.opensuse.org"
All files downloaded, will call slotRunApp shortly
EXEC "/usr/bin/firefox /home/peteh/.cache/kioexec/krun/7198_0/unnamed"
EXEC done

My default browser is set to firefox in system settings and always has been.

Okay that does not look good, for me it work and looks like:

$ xdg-open https://forums.opensuse.org
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'" 
kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"

After that the tab is opened in Firefox.

The relevant error looks to me:

kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job.

Searching for that on the Internet gives some hints.
Can you try:

$ xdg-mime query default x-scheme-handler/http  
firefox.desktop 
$ xdg-mime query default x-scheme-handler/https 
firefox.desktop

Does it list anything else for you?

Do you have the package kmozillahelper installed?

Regards

susejunky

It started to work properly again yesterday. The only thing I did was make a slight change to a desktop widget for firefox but I can’t think that would have made a difference (I added the “%u” after the command).
Anyway, it’s now working as it should so thanks for all you responses.

Why wasn’t it there in the first place? That is rather crucial.

I have been searching for this problem because I have exactly the same problem described.
I’m using Leap 15.3 and plasma 5.18.6.
Firefox is the default browser.
When I open most links it opens a local file instead

fernando@andromeda:~> xdg-open https://forums.opensuse.org 
fernando@andromeda:~> command= "firefox" args= ("firefox", "https://forums.opensuse.org") 
kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job. 
Copying QUrl("https://forums.opensuse.org")  to QUrl("file:///home/fernando/.cache/kioexec/krun/6808_0/unnamed") 
Telling kioexecd to watch path "/home/fernando/.cache/kioexec/krun/6808_0/unnamed" dest "https://forums.opensuse.org" 
All files downloaded, will call slotRunApp shortly 
EXEC "/usr/bin/firefox /home/fernando/.cache/kioexec/krun/6808_0/unnamed" 
EXEC done

I found the problem.
In system setting I had set web browser to “with the following command” set to
firefox
I changed it to /usr/bin/firefox and it works

I my KDE System Settings, the “with the following command” is not checked at all.

I have three options

*In an application based in the contents of the url
*in the following application
*with the following command

in the second option only chromium, seamonkey and opera appear, so y used the third one

I have the same three option.

But the second shows Firefox or Konqueror only (which is correct, I do not have any other installed). I never changed there, because Firefox is nowadays the default in KDE and thus this was already as it is now surviving several upgrades.

Thus I guess the strange thing here is that you do not have Firefox in that list, although you have it installed?

One funny thing more.
In some applications (for instance I use telegram app to use telegram and rambox to use whatsapp in the pc) the links where not working, after changing the “with the following command” now they work … but with chromium!!! but there is not set in any of this applications to use chromium. Then I change the system settings to “In an application based in the contents of the url” open one of these programs, click on a link and it opens firefox, but not the link. And if I set “in the following application” and set opera, then it open the link with opera

and then I change again to “In an application based in the contents of the url” and it continues using opera, and I change again to “with the following command” and it continues using opera too

Sorry I have no idea why this seemingly random use of browsers. I only wanted to show you what I have in a rather bland situation: only standard installed browsers and never (in this area) changed KDE config.

When using those settings, I click on the small icon to the right of “with the following”. That gives me an application window where I can find “firefox”. This should set it the way that KDE expects.