cli instead of graphical login with kde3/4

I just upgraded from 11.0 to 11.1 - keeping the same setup with both KDE3 and KDE4 (and GNOME) all installed. By default, it now gave me the KDE4 KDM login - a change from the KDE3 version I had previously. All was going fine and I’d logged into KDE3 with no issues, but one subsequent reboot dumped me at a command line login. After another reboot, everything was okay again, so I logged into both KDE3 and 4 a few times and had almost everything how I wanted it. Now it’s started dumping me back at the command line again, every time.

It’s in init5 mode already, and I can startx which always brings me to KDE3 as either root or user. I also just tried booting into failsafe mode, which gave me a graphical login but only in a reduced resolution in the middle of my screen and lower colour depth.

If I try ‘startkde’ or ‘startkde3’ it gives an error message about the x server not working or not being set up correctly.

How can I get it all back to normal?

May have solved my own problem, though my typing here after just one successful login will probably now curse it. Just for the benefit of anybody else who has these issues:

Tried a combination of things and not sure exactly which one was responsible for salvaging the system. Firstly I reinstalled all the packages relating to kdm, but next reboot was still to a cli. Then I found that the ‘Configure Desktop - Personal Settings/KDE4’ (aka KDE4 Control Centre) was available in the kick-off menu of KDE3 under Root, so I went in there and made a couple of adjustments to the Login Manager (under the Advanced tab). Meaningless ones, but just for the sake of overwriting the existing config file. Finally, I launched Sax2 and made a couple more (probably needless) adjustments to my monitor setup (the diagonal size and aspect ratio had never been setup correctly).

Doing one of these things seems to have reconfigured the system correctly, I just can’t be sure which one. I’ll need to log in a few times as both root / user under all DE’s before knowing if it’s sorted for good or something’s buggy.

Nope, I cursed it with my previous post. It’s all ballsed up again now. One more reboot and I’m back at a command login. If I try ‘startkde’ or ‘startkde3’ I get the following:

“$DISPLAY is not set or cannot connect to the X server”

I don’t see anything obviously wrong with my xorg.conf file.

I’m wondering whether there is a bug related to KDM / KDE in openSUSE 11.1 whereby switching between the desktop versions throws the system somehow. If anybody else is on 11.1 and happily using both KDE3 and KDE4, switching between them and rebooting to a graphical login every time, can they post here and let me know? Cheers.

I’m doing this on 3 PCs, … with no problems.

In all 3 cases I did a complete clean re-install of 11.1 (including a clean install of /home) and I initially chose KD3 as my desktop (and hence obtained kdm from kde3). I only added the KDE4 base package later.

I also ONLY access kde3 from user-a and ONLY access kde4 from user-b. I do NOT access kde3 from user-b nor do I access kde4 from user-a.

That removes, as best I can, the possibility of some config file having a problem swapping between versions.

I’m currently not at a Linux PC, so I can’t provide any more detail than that.

I seem to be getting nowhere with this, except for slowly ruining my system by making various configuration changes in an attempt to diagnose the problem.

I’ve tried reinstalling all Xorg packages, running Sax2 -r and manually amending the Xorg.conf file, re-running the KDE4 Login Manager and changing things, checking out 101 other configuration and log files around the system and seeing if I can find any hints.

I’ve read a few comments on forums about the latest Xorg being problematic on some other distros, and I wonder if that has anything to do with it, since I’m using an ATI graphics card with a default configuration of the free radeon driver. After upgrading to 11.0 I finally saw some kind of acceleration features - on screensavers at least. Now with 11.1 I can get Google Earth running properly for the first time ever. ‘My Computer’ shows 3D support as existing, and ‘dri’ has been loaded into the xorg.conf file. I’m reluctant to try the proprietary ATI driver since all attempts to do that in the past were fraught with problems, but I have suspicions that the radeon driver bundled with 11.1 may not be up to the job, at least with my card / configuration.

Otherwise, I don’t know where else to turn. After three and a half years using SUSE on this laptop (since 9.2) I’m suddenly left with a non-working configuration. Some progress that is.

Would these items seen in the scrolling messages when attempting ‘startkde3’ have any bearing?

xrdb: cannot open display ‘’
kdeinit: aborting. $DISPLAY not set
xprop: unable to open display ‘’

There were many more and one about DCOP, but some scroll off screen too fast and I don’t recall what they were.

Just a stupid question, but what video card do you have? If it’s ati you need to compile the drivers.
Otherwise, have you tried conguring the video with sax2?

It’s an ATI Mobility Radeon 9700 (RV350 NP). I’ve configured it under Sax2 many times, trying a few variations with the monitor config. There’s a lot of obscure supplementary options for the video card in Sax2 but they’re all undocumented and meaningless to me. I noted that on some reconfigurations it had disabled the “dri” option in my Xorg.conf file, but whether the 3D acceleration is working or not, that still doesn’t solve the login issue. I have also changed the acceleration method from XAA to EXA after noting some errors in the logs, but again it seems to be irrelevant to the problem I have.

I should have mentioned previously that swapping between KDE3 and KDE4 is probably not the culprit either, since the problem re-emerged after logging in exclusively to KDE3 today. Getting a graphical login is practically a thing of the past on this machine now. Everything I try fails, and on those few occasions that it worked before, I was unable to repeat any procedure that caused it to happen again.

The ‘$DISPLAY not set’ messages must be key to this, but what do they refer to exactly and how do I fix it?

Did you try downloading the ati driver from ati/amd and installing it? I found this fixed my ati problems.
There are other threads with the how to’s for downloading, etc.

Haven’t done so yet. It’s about the last thing I’ve yet to try. I’m waiting for the ATI repository for 11.1 to be up and running and for their January driver release (although I suspect that official SUSE 11.1 support won’t arrive until the February release).

I tried the ATI installer in the past on another similar system and it caused a lot of problems, so I’d prefer to do it via the repository.