Clementine problem

When i try to open a mp3 file with clementine i get “GStreamer could not create the element: autoaudiosink. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)”. Can someone help me to fix this? I have installed gstreamer but its still not working. I am on latest tumbleweed.

Clementine still uses (only) the old gstreamer 0.10, so make sure that you have the necessary gstreamer-0_10-plugins installed.

For MP3, this would be gstreamer-0_10-fluendo-mp3, which is not installed by default I think, only gstreamer-fluendo-mp3 is.

“autoaudiosink” should be part of gstreamer-0_10-plugins-good, so check that you have that as well.

Wolfi is exactly right (as always). clementine uses gstreamer-0_10-fluendo-mp3 which you can install from:
http://download.opensuse.org/update/13.2-non-oss/x86_64/

that fixed the issue, thanks :slight_smile:

Just confirming that the two specific packages that need to be installed for clemetine to play .mp3 files are:
gstreamer-0_10-fluendo-mp3 and gstreamer-0_10-plugins-good

this is what I have:


blackbird:~ # rpm -qa | grep fluendo
pullin-fluendo-mp3-13.2-11.4.1.noarch
gstreamer-fluendo-mp3-21-5.3.1.x86_64
gstreamer-0_10-fluendo-mp3-21-5.3.1.x86_64
blackbird:~ # rpm -qa | grep gstreamer | grep good
gstreamer-0_10-plugins-good-0.10.31-13.1.9.x86_64
gstreamer-plugins-good-1.4.3-1.1.x86_64