Clementine mess up tags

Hi,
I have a very annoying problem (and I tend to believe this a bug) when I try to edit some tag in any mp3 file I have that need to contain some special characters.
For example: I have a misspelled tag for a song Unheilig - Der Vorhang Fällt – my wrong title was Faellt – and I wanted to correct this; tried it, as usual, inside my preferred player, Clementine, which was perfect for this role for such a long time ago …
Well, now, in my OpenSUSE 12.3 system I can’t do it anymore !!!
That is, when trying to correct that misspelled word, instead of “Fällt”, clementine writes something like “Fällt” in the file !!!
What’s worse is that, now after editing that word in the title, my clementine sees it like … this (the song with number 17 before it):

http://oi46.tinypic.com/2z65phz.jpg

What a horror !!! (yes, believe it, that is how clementine shows the title, after I edit it to correct that word !!)

How’s this even possible ??? Considering OpenSuse is a german product (despite any Novell subordination … if any) … how could you guys managed to mess this up so bad ???

kid3 did this exactly the same ! (when trying to copy/paste the correct word, at save time it just messes it up and gets it into the same very wrong form…)

It’s my first time when I get this sort of behavior (ALL other previous OpenSuse version have these applications doing it the write way (with this “special” character “ä”, but other same genre of characters (not only from German language …)

So … please, anyone … what can be wrong in my installation ? (anything that may be missing – at the fonts “department” ? any bad library that clementine, kid3 or other similar applications uses ?

Luckily, I found another mp3 tag editor (easytag) that CAN do this editing correctly (and after that, clementine shows the title correctly – but should I try to edit it, after that, within clementine, again, no matter at what part of the title, it saves it wrong, again !! )

BUT … since I very much prefer editing tags in my mp3 files within clementine (I really like the way it lets me edit tags, even multi-edit tags) … I’d rather prefer to have the fix for this bug …
Any suggestions on what should I try to modify in my system ? I can’t believe I just have to resign myself to this until the next version of Opensuse…

I do not know anything about Clementine. but your experience seems to come from the fact that some partner in what you do (Clementine?) is not working in UTF-8 Unicode and thus messing up the character encoding.

Somewhere in my first post I mentioned that kid3 did the same thing (exactly the same result, even that horror of title that appears in the picture…). Since they are (so) different, I tend to think the problem may lay somewhere else …

Is that a fresh openSUSE 12.3 install or an updated system, if updated
what was there before?
Can you post the output from the command


locale

and also what file system you are using, ext4, xfs whatever elese (that
may be unrelated but just to be sure).


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

I have a fresh install of Opensuse 12.3 (I always do this, I never upgrade the current version over the older one …).

Partitions are (all of them) ext4…

results from locale command:
LANG=POSIX
LC_CTYPE=en_US.UTF-8
LC_NUMERIC=“POSIX”
LC_TIME=“POSIX”
LC_COLLATE=“POSIX”
LC_MONETARY=“POSIX”
LC_MESSAGES=“POSIX”
LC_PAPER=“POSIX”
LC_NAME=“POSIX”
LC_ADDRESS=“POSIX”
LC_TELEPHONE=“POSIX”
LC_MEASUREMENT=“POSIX”
LC_IDENTIFICATION=“POSIX”
LC_ALL=

I don’t have any secondary language installed, only english-US (though I DO have the keyboard layout set to RO (romanian) as primary layout).

This is what I get


martinh@ganymed:~> locale
LANG=de_DE.UTF-8
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=
martinh@ganymed:~>

ignore that I have german locale, that is more or less not relevant, but
everything is set to UTF-8 (unicode) while yours is not set to unicode.
What bugs me most is that you have LANG=POSIX, I suspect that is where
your problem comes from, at least the language should be something like
en_US.UTF-8

So it looks like that your programs completely correctly save everything
as UTF-8 and then somehow it gets messed up because what was saved as
UTF is later interpreted as ASCII when reading.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

I changed the locale (in my /etc/sysconfig/language file) to look like that (well, with en_US.UTF-8 actually), logged-off (even restarted, later) but … nothing changed in the way clementine and kid3 behaves (the same “convertion” into that mumble-jumble characters…)

You do not need to change system settings to do such a test, a simple


LANG=en_US.UTF-8 clementine

would have been enough to test that.

If it is not the language setting which affects the interpretation of
the encoding then I am afraid I have no idea what else in your system
produces this behavior.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

Unfortunatelly nothing changed in clementine’\s behavior (same result when saving the modification to that file’s tag …)
I’m thinking of uninstalling the current version of clementine, an then re-install an older version (like that from Opensuse 12.2, 12.1 … ) and try this again. If this “trick” do the job, than it’ll be obvious a bug in clementine (either from mainstream, of from Opensuse team itself …). I’ll come back with the result of this …

I installed now clementine to see how it behaves on my system (version
is clementine-1.1.1-3.1.3.x86_64 on openSUSE 12.3), when I edit a title
and set a Umlaut like ä I can see the same error as you, it is shown
crippled.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

Am 14.04.2013 12:17, schrieb Martin Helm:
> I installed now clementine to see how it behaves on my system (version
> is clementine-1.1.1-3.1.3.x86_64 on openSUSE 12.3), when I edit a title
> and set a Umlaut like ä I can see the same error as you, it is shown
> crippled.
>
Looks like an upstream problem for clementine which exists for years
http://code.google.com/p/clementine-player/issues/detail?id=811


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

I also installed now kid3 and that is at least consistent in that it can
read again the umlauts I stored using kid3 itself, it also has a setting
where I can say which encoding to use (the default setting after fresh
install seems to be ISO-8859-1 latin also known as western ISO which is
more or less identical with the old cp1252 windows standard. Not very
clever to say it friendly.

But at least it lets you set what you want and need.


PC: oS 12.3 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.10.0 | GTX 650 Ti
ThinkPad E320: oS 12.3 x86_64 | i3@2.30GHz | 8GB | KDE 4.10.2 | HD 3000
HannsBook: oS 12.3 x86_64 | SU4100@1.3GHz | 2GB | KDE 4.10.0 | GMA4500

I think I had that kind of modification (hopefully I do remember exactly that I had to do some corrections to several Mötley Crüe songs, and have succeeded in editing the artist name exactly like that, (not as Motley Crue !) with clementine …either with version 0.7, under opensuse 11.4, or with version 1.0 under opensuse 12.1…

So, then … I just have to resign myself into … editing the hard/complicated tags (like these ones with non-ascii characters (umlauts as in German, or Greek letters …) with other pieces of software (like “easytag” which did this job correctly) … ?
If so, there’s nothing but a bad taste in my mouth … again …

Funny thing is …Rhythmbox player doesn’t mess up editing of such tags (with extended-ASCII characters…)
Even more then that: After I edit the tag with clementine (and it, of course, ruins the tag…), when I open the file again in Rhythmbox, this one just shows the tag OK !!!
This is really interesting… could this actually be a matter of displaying the tag ?
Also, the internal viewer (F3) in Midnight Commander (mcx) show the tag with correct characters…
But,mpg123 does not.
But, still, mplayer also shows it correctly (even clementine and other does not…)

On 2013-04-15 21:46, corneld wrote:
> So, then … I just have to resign myself into … editing the
> hard/complicated tags (like these ones with non-ascii characters
> (umlauts as in German, or Greek letters …) with other pieces of
> software (like “easytag” which did this job correctly) … ?

Easytag has a set of rules for automatic changes it applies to the files
you browse: they display in read. If you save the file, the change is
applied and that file(s) displays in black.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Some newinfo about the problem:

I started clementine from konsole (to watch closely the messages it writes down …), and: when trying to edit the tag, and save it with the correct value, I see the following on the terminal:
21:31:02.370 WARN UniversalEncodingHandler:160 Extended ASCII… possibly should be CP866 or windows-1251 instead
21:31:02.371 DEBUG MessageReply<MessageType>:93 Releasing ID 1 (finished)

And, very interesting: if I try to PLAY the song with the corrupted tag, clementine actually corrects it back on the go (I mean: while it’s playing the song, the broken tag now shows correctly !!!); while playing I see these messages on konsole:
21:29:23.528 DEBUG unknown <nowplaying>
21:29:23.528 DEBUG unknown <track corrected=“1”>der vorhang fã¤llt</track>

Oh yes, but after stop the play, the tag becomes corrupted again …

Anyway … it seems (extremely probable) that this is an issue with the package taglib included with OpenSuse (now 1.8-3 – and even 1.8-55 if you add repository multimedia:libs and choose update to it’s version of taglib …)
According to these bug reports:
https://bugs.kde.org/show_bug.cgi?id=309693
https://github.com/taglib/taglib/issues/129
and, most relevant:
https://bugzilla.novell.com/show_bug.cgi?id=814814