Cleaning up / now mouse and keyboard not working on startup

Was running out of room on / and set in Yast to delete /tmp on startup. Also deleted /var/log and /var/tmp while logged in. Rebooted and now mouse and keyboard (both USB) not working. Keyboard works on grub menu. Also works now in XP. Tried reconnecting (sync & plug unplug) different usb ports and nothing. Gave it a few minutes on startup and still nothing. Plugged in a PS2 keyboard and the lights just blink after startup and it will not work either.

Bit stumped on what the best way to get them working again. Suggestions appreciated.

DigitalCore I have three suggestions for you because I do not know what is screwed up on your computer.

Suggestions #1, this might be the right time to download and upgrade to openSUSE 11.3, you could even try an upgrade (as opposed to a new install) to see if it will fix your problem.

Suggestions #2, never manually delete any file unless you read an article from a well known source here telling you so that you know is the truth.

Suggestions #3, in order to have the /tmp directory cleared for you automatically each time your reboot make the following changes in openSUSE.

Open /etc/sysconfig/cron, search for a line saying

CLEAR_TMP_DIRS_AT_BOOTUP="no"

…and edit “no” to “yes”. This could also be done via GUI: YaST → “Editor for /etc/sysconfig”.

Or you can edit the file as root. Using the menu Run Command:

kdesu kwrite /etc/sysconfig/cron

Enter the root password and make the changes suggested above and you are done.

Thank You,

Thank you for the reply
#1 will look into further. Good idea. Just tried and I get this. Will try later. (error page for 64 bit) http://download.opensuse.org/distribution/11.3-RC2/iso/openSUSE-DVD-Build0694-x86_64.iso
#2 Actually got the info from the forum here on what to delete, still have no idea why they (KB & Mouse) will not work. Tried failsafe mode and keyboard won’t let me put in password to boot.
#3 thats exactly how I had enabled it
I use Keytouch with no problems (past 8 months ) not sure if that had something to do with the problem or not.
Where does the trash from root go? I checked the trash in the home folder and it was all old files that I recently had cleaned up ( office docs pdf’s etc.) One theory is I may have deleted more on accident in the var folder not realizing. Stumped on why it will load but cannot use mouse or keyboard. If I can access trash and undelete that might fix it.
Thank you for your help

You are going to have to wait unit 7-15-2010 to find the new download link I am sure, but that is just tomorrow.

Suggestion 3 is the way to delete the /tmp files and this is done for you automatically. I have had no problems with this method. I am sure the files that are deleted are simply gone, just like using the Delete command in a file manager when this command is enabled. The files were removed and not moved to the trash.

Thank You,

Downloaded the DVD today, ran the update to 11.3 and that fixed the keyboard and mouse problem (posting this using 11.3).
Now the dual moniters won’t work. :slight_smile: Unplugged one of them but still cannot change screen size and need to figure out how to get nvidia drivers working again. (been a while since I set them up)
If I start poking around in configure desktop the system freezes to make things more fun.

One step closer to a functioning computer.
Thanks for your help

For the installation of nVidia cards you should look at this writeup first.

SDB:Configuring graphics cards - openSUSE

Here is the list of actions I used to install the nVidia drivers as I installed openSUSE 11.3:

  1. During the install, when you have the option to change your booting setup, I add nomodeset to the kernel load command for the normal load/start of openSUSE. This kernel startup option is already present for the Failsafe selection for openSUSE.
  2. During the first start of openSUSE, I download the latest nVidia Video driver to the downloads folder.
  3. I change/save the System/Kernel option NO_KMS_IN_INITRD from “No” to “Yes” in the /etc/sysconfig Editor in Yast.
  4. I do an update of openSUSE on the first run of openSUSE and then a restart/reboot.
  5. In grub OS selection I add the command line option “3” to the openSUSE start line so that I just go to the run level three terminal prompt.
  6. I login in as root and change to the /home/user/Downloads folder.
  7. I run/install the NVIDIA video driver using “sh ./NVIDIA-Linux-x86_64-256.35.run” and answer all questions as appropriate for my system.
  8. Type in reboot at terminal prompt to restart the system with new video driver.

Read it all through a couple of times. I had someone else say it did not work, but then came back and said it did and perhaps they had missed a step the first time through. It does work, once you understand what is going on.

Thank You,

Ok got Nvidia up and running again. Thank you for your help. Have some “issues” (weird ripple on screen) when watching videos. Think its the refresh rate? Will play around with the xorg file (after making a backup : ) ) and see if thats the cause. One monitor is a 26 and the other is a 19 and they have different resolutions etc.
11.3 working pretty good. The upgrade went smoother than the 11.2 upgrade so happy about that.
The really funny part is I still only have 3 gigs free on my 20 gig / that I have to clean out. At least now I know what not to do.

DigitalCore at least it sounds like you are getting closer to being setup properly. If you have another question please do not hesitate to ask for help here.

Thank You,