Clean net install 12.2. After updates no video after the initial boot selector.

I did a fresh clean install net install of 12.2 KDE then ran updates from “apper” since it and packagekit were totally blocking my use of the YAST2 software installer and repository configuration menus.
After the required reboot I had no video after the initial boot selector video went away and I can’t get it back no matter what I do.
CTRL-ALT-F1 does not bring up the console. How do I fix this mess?

Core 2 duo with Intel on board graphics and 4 gigs of memory on this machine. It was running so sweetly until I did the recommended updates.

Updating. If I selected advanced boot options and select the second boot option I get a graphical desktop abet not at 1920X1080 but and 1280X1024. I believe this is the “recovery mode” perhaps. Still not right and I still am pretty lost. this Grub2 and Plymouth stuff is complete foreign to me. No idea where to start on the “fix” with this boot issue.

I am facing similar troubles.
So far, I have no solution, but I’m investigating whether my ATi Catalyst proprietary graphics driver can be the source of the problem. Are you using the same driver or at least any kind of graphics driver that might require recompilation?

A similar suggestion was made on Google+ by someone that uses a different distro. I am hoping that isn’t so. I haven’t rolled my own kernel in at least 8 years.
I would suggest this that in 12.1 using the Nvidia proprietary driver installing a new kernel from Yast2 calls in a script that rolls you a proper kernel. I don’t know what apper dragged in.
As far as I know I am not using anything but the default video generic driver installed by the installer.

I somewhat solved my problem. I installed a low profile Nvidia 8400 video card. It boots. It’s not pretty but it boots and reboots reliably with video every time.
I prefer a wall of scrolling text to the blank screen I am getting during the boot process after the initial openSUSE splash screen after the grub2 chooser.

This still doesn’t remedy the problem with the Intel graphics fail but it works.

I suppose I solved my issue.

My problem:
After accepting Apper updates that included changes in X11, my (proprietary) graphics driver was unusable: when booted in normal mode, the system hung up; when booted in failsafe mode, the system went to an useless black screen with mouse pointer, but nothing else.

My solution:

  1. booted up my system in command line;
  2. logged on as superuser;
  3. removed my ATi Catalyst driver, by typing aticonfig --uninstall
  4. restored my original Xorg.conf file, by typing cp /etc/X11/xorg.conf.original /etc/X11/xorg.conf
  5. restarted operation system, by typing /sbin/shutdown -r now
  6. at this point, I was already able to log on to a graphical environment – a quite basic, low resolution one, without OpenGL, but… a GUI;
  7. I downloaded a fresh copy of my graphics driver from AMD website, installed and configured it interactively.
  8. Rebooted… and everything seems fine.

My system never hung it just had no video.
I got the KDE “chimes” went the desktop environment finished loading hitting the power button issued a orderly system halt.
Now I have the Nivdia card installed using the generic open driver the system works normally.
Something flaky with the old Intel video and detection in what ever new was installed.