Clean install - freezes immediately - no GRUB screen

The hardware is a little unusual: Intel server motherboard S3420GP with Xeon X3440. Age approximately 2011.

This machine was running previously on Leap 15.2 with a non-EFI setup. I can still boot it using that drive.

Attempting fresh 15.3 install on new drive using default installer options, which includes an EFI setup.

After restart & post machine immediately freezes when it attempts to boot. No GRUB screen.

Checking the motherboard config, it appears to recognize “opensuse” as a legitimate EFI choice for boot.

Have tried both “secure boot” and not during install.

Have tried resorting to adding MBR choices but unsuccessful.

I have attempted to duplicate the old drive set-up but the Leap installer complains and won’t proceed.

Without any error messages I don’t know how to diagnose.


If you boot the install media (in EFI mode), there should be an option “boot from hard drive”. Does that work?


The trick was to manually take control of the partition-making during installation and create a 1MB FAT-32 “bios boot” partition at the start of the drive. Then an EFI partition (although I will likely never use it). Then the usual OS and swap partitions.

The final screen of the installer before committing allows the boot loader options to be changed. Here, I changed the default EFI options to BIOS choices.

The 1 MB “bios boot” partition at the start of the drive was what I had been missing.

I may have been able to cut the EFI partition, but it’s there now, and the system works.

I’m glad to hear that it is working.

That new drive was likely configured gpt rather than dos, hence the pmbr setup for legacy boot.

Usually 8 MB FAT-32 “bios boot” partition at the start of the drive, not 1 MB.
Try to update mobo BIOS:
EFI boot may work after BIOS update.
IMHO you can load openSUSE installer in legacy mode to get legacy partition layout.