Clean install 11.4 Dual Boot System Grub Error Please Help!

**I did a fresh install of SuSE 11.4 (WIN7 TOO) and changed my Larger HD1 to the first HD. I was installing and got this error first: the boot loader is installed on a partition that does not lie entirely below 128GB The system might not boot if BIOS supports only lba24 (result is error during install grub mbr) status loc dev/sdb6

I continued with the install and then got:

Yast2 error occured
while installing GRUB ver 0.97 (640k lower/3072k upper memory)
[minimal bash-like lineediting is supported? for the first word, TAB lists possible command completition anywhere else TAB lists possible completion of a device/filename]
grub setup --stage2=/boot/grub/stage2 --force4-lba (hd0,5) (hd0,5)
Error 25
disk read error
grub> quit**

fixed it…installed 11.3 64 bit…no problem…it is the disc I think for 11.4

Only yours. 11.4 installed fine for me from the DVD. Did you run a media check?

I am facing the same issue, and am not able to reinstall 11.3 again as I get the same error message for Grub. :frowning:

I have a Lenovo Ideapad with 3 GB Ram and have partitioned my disk into 7 with sda2 being C: drive. I had created an unpartitioned space of 100 GB while installing windows on which I am trying to install linux. I also created a 1 GB partition, sda6 for my swap area and the rest of the unpartitioned space as sda7 for mounting / .

Please help.

The original post mentions 2 errors, the most common is that of the partition not being below the 128GB limit. Is this what you mean?

Are you using a Live CD to install? If you are we can use that to find some info out. Otherwise I need you to download Parted Magic


Thanks for your reply. Strangely, i didnt get any update on your reply in my gmail and hence the delay in this reply.

I am using a live CD to install. When I installed, it showed me total 7 partitions in my sda disk. sda1 was a system required of 100 MB. Sda 2 was my C: drive which is NTFS format. Sda3-sda5 are all windows partitions. I used sda6 as swap (1 GB) and sda7 to mount my root partition. Everything goes fine untill Grub install happens when I get the same message as said in the first mail. When I try to configure it manually the disk names for all my windows partition is gibberish and even if I change them, GRUB doesnt get installed. So when I reboot it boots into windows directly.

Please let me know if you need any extra info.

Boot the live cd
open a terminal and in it type: su (then hit enter)

Now type: fdisk -l
(that’s a lower case L)

Post the result for me
(You may need to save it to a file and flash drive)

@caf4928 : Thanks again. Here’s what you requested:

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x5cb4769a

Device Boot Start End Blocks Id System
/dev/sda1 63 2047 992+ 42 SFS
Partition 1 does not start on physical sector boundary.
/dev/sda2 * 2048 206847 102400 42 SFS
/dev/sda3 206848 314574847 157184000 42 SFS
/dev/sda4 314574848 1250261679 467843416 42 SFS

Disk /dev/sdb: 4051 MB, 4051697664 bytes
64 heads, 32 sectors/track, 3864 cylinders, total 7913472 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd704f98b

Device Boot Start End Blocks Id System
/dev/sdb1 * 0 1423359 711680 83 Linux
/dev/sdb4 1423360 7913471 3245056 83 Linux

Disk /dev/sdb1: 728 MB, 728760320 bytes
64 heads, 32 sectors/track, 695 cylinders, total 1423360 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd704f98b

 Device Boot      Start         End      Blocks   Id  System

/dev/sdb1p1 * 0 1423359 711680 83 Linux
/dev/sdb1p4 1423360 7913471 3245056 83 Linux

Sorry for the delay in reply again, didnt have access to my system

That’s a rats nest of nasty win SFS
And not really making sense from your comments in post #6

Well … The partition table is not encrypted. Only the partition IDs are different. So fdisk doesn’t get the extended partition, while the openSUSE partitionner assumed it was the last one, jumped to the address of the next logical, etc. What about replacing 0x42 with 0x0F on sda4? But honestly, I have no idea what SFS does. It doesn’t seem appropriate for a dual boot, that’s for sure.

Found one major clue to solve this problem. Turns out I have dynamic partitions in my Windows system and was trying to install opensuse in one of those partitions. Not sure if this was a reason or not but now will try to re-install windows with basic partition and let you know the results.

Thanks for your help anyways guys.

PS: Was blocked from posting on this thread for some strange reason. And now its working normally by itself again.

Keep us informed
Don’t know about your posting issue. Let us know if you have any more trouble.


I have the same problem as the original poster. The desktop is a new AMD A8-3860 CPU, Windows 7. OPENSUSE 12.1 86X64 cannot continue at the grub configuration. The error message is the same with the OP.

I run rescue disk, fdisk -l. It shows:

Device Boot Start Ends Blocks Id System

/dev/sda1 * 7 HPFS/NTFS/exFAT
/dev/sda2 7 HPFS/NTFS/exFAT
/dev/sda3 7 HPFS/NTFS/exFAT
/dev/sda4 f W95 Ext’d (LBA)
/dev/sda5 82 Linux Swap / Solaris
/dev/sda6 83 Linux
/dev/sda7 83 Linux

I omit the cylinder number etc. Hope it does not affect the diaganosis. Please help me on how to install 12.1 X64 on my desktop? Thanks.

Try this
Download this:

Burn it to a CD and boot from it
Use the Partition editor to put the boot flag on sda4
See this guide:
Just pay note to the boot flag part

Once done, try rebooting.
If it still fails, try following this
Re-Install Grub Quickly with Parted Magic

Thanks. I did not describe clearly in previous post. When install SUSE 12.1 X64, it warned that bootload position larger 128 GB, Error 25 etc. After installation, reboot failed, either Windows 7 or SUSE. Using GPARTED made Windows 7 bootable and using Windows 7 system DVD saved Windows. That is, SUSE never bootable with Boot flag.

During Install You should set to boot from root and write to MBR
You can toggle at this part of the install