Citrix 13.9 on Leap 42.3

Good morning
I am a new Opensuse user and I am having difficulty configuring Citrix ICAClient. I think I have properly downloaded and installed the package though YaST. When I log in I can get as far as logging in to my company’s server and when I try to open the remote desktop it downloads but never opens. I recently set up Citrix on multiple Ubuntu based systems and had to load various security certificates but I am not getting any SSL errors. Any suggestions or assistance would be appreciated!


Welcome. :slight_smile:
Try start firefox (or what browser you use) from a terminal (konsole or terminal). Software use to pass information there, if you don’t se any special copy information and paste it to and link to this thread.


Embarrassed to admit this… I do not know the commands to do that on Opensuse…

Additionally, I upgraded to Leap 15 today. When I set up Citrix on Ubuntu based systems it was a matter of downloading the right security certificates. I think I need to figure out how the commands differ between Opensuse and Ubuntu - and I was just getting the hang of using terminal in Ubuntu.

Were the instructions given in link I provided in the other thread not sufficient?

I’m sorry. Firefox starts without a problem from terminal. No errors.

Just a thought - Is the Citrix Receiver plugin activated in firefox?

I think so, let me verify

It doesn’t appear as an add-op or plug-in in Firefox. However, I am also running my other laptop (Kubuntu 18.04LTS) and checked Firefox and it isn’t showing up there either and I am able to use Citrix on that machine.

I tried to access through Chromium and it connects to the server (like Firefox) but it won’t open the desktop and I get the following error:

“Cannot connect to “ - Clinical Desktop”
No such file or directory. Verify your connection settings and try again”

I also downloaded dpkg to try and get it working using .deb to share the security certificates and this is what I get:

jlapin4@linux-spz2:~> sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/ICAClient/keystore/cacerts/

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for root: 
ln: target '/opt/ICAClient/keystore/cacerts/' is not a directory: No such file or directory

You need to install ca-certificates (if they aren’t already) and then either link /opt/Citrix/ICAClient/keystore/cacerts to the ca-certificates key dir or copy them from the ca-certificates to the /opt/Citrix/ICAClient/keystore/cacerts dir (what I did)

Then either kill all Citrix executables (if you don’t know which one just reboot). It should work fine now.

do you happen to know the command line input to share them? I’ve tried:

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/ICAClient/keystore/cacerts/

And get:

jlapin4@linux-spz2:~> sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/ICAClient/keystore/cacerts/
[sudo] password for root: 
ln: target '/opt/ICAClient/keystore/cacerts/' is not a directory: No such file or directory

Can you verify Citrix is actually installed in /opt?

Else try something like

find -name ICAClient

when you are in /


That is what I get when I run

find -name ICAClient

didn’t give me any output

From which directory did you run find?

Ok, here is where I will look clueless… I am not sure, I am in Konsole and at the prompt I ran the command. What is the proper way to run it as root?

I ran

sudo find

and I received the same output as above

sudo find / -name ICAClient
jlapin4@linux-spz2:~> sudo find / -name ICAClient
find: File system loop detected; ‘/.snapshots/1/snapshot’ is part of the same file system loop as ‘/’.                                                                          
find: ‘/run/user/1000/gvfs’: Permission denied