Cisco LEAP works on 12.2 BUT not 12.3

Hi all,

I’ve got openSUSE 12.2 and 12.3 (dual boot) on my Toshiba Tecra laptop. In short, I can connect to home(WPA2) and corporate(Cisco LEAP) on my 12.2 with NetworkManager BUT not with the latest 12.3 on Cisco LEAP.

tail -f /var/log/NetworkManager:

NetworkManager[775]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
NetworkManager[775]: <info> Config: set interface ap_scan to 1
NetworkManager[775]: <info> (wlan0): supplicant interface state: inactive → scanning
NetworkManager[775]: <info> (wlan0): supplicant interface state: scanning → authenticating
NetworkManager[775]: <info> (wlan0): supplicant interface state: authenticating → disconnected
NetworkManager[775]: <info> (wlan0): supplicant interface state: disconnected → scanning
NetworkManager[775]: <info> (wlan0): supplicant interface state: scanning → authenticating
NetworkManager[775]: <info> (wlan0): supplicant interface state: authenticating → disconnected
… … …
Activation (wlan0/wireless): association took too long.

The above repeats for quite a few cycles and it gave up.

I’ve even upgraded NetworkManager (0.9.8.0) & NetworkManager-kde4 (0.9.0.8) to the latest versions in Factory and the only difference is the above attempts lasts longer and it asks me to re-enter my LEAP password two-to-three times before it gave up.

I tried downgrading NetworkManager to the version in openSUSE 12.2 (0.9.4)… bad idea. :\

  1. Can anyone who has successfully connect up to Cisco LEAP network help me out?
  2. Can any developer advise what/where are the knobs to tweak this timeout so that it can wait a little longer for association?

PS: This Cisco LEAP connectivity challenge is not new (from my perspective), I find that with almost every new release of openSUSE, connectivity with LEAP breaks and it doesn’t get fixed till a later update. Further, the error message is always along the lines of “association took too long”. Sigh. I know Cisco LEAP is not as ubiquitous as WPA or other common wifi authentication mechanism… but I would assume that if its working in previous versions, then it should continue working in newer versions since the root issue (from my perspective, I could be wrong) has to do with timeouts in association with the wifi access point… I don’t think the Cisco LEAP standard or implementation has changed that frequently. Sorry, just venting here. :expressionless:

Any help and pointers appreciated. Cheers! :slight_smile:

On 04/14/2013 10:16 PM, kamhw wrote:
>
> Hi all,
>
> I’ve got openSUSE 12.2 and 12.3 (dual boot) on my Toshiba Tecra laptop.
> In short, I can connect to home(WPA2) and corporate(Cisco LEAP) on my
> 12.2 with NetworkManager BUT not with the latest 12.3 on Cisco LEAP.
>
> tail -f /var/log/NetworkManager:
>
> NetworkManager[775]: <info> Activation (wlan0) Stage 2 of 5 (Device
> Configure) complete.
> NetworkManager[775]: <info> Config: set interface ap_scan to 1
>
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> inactive → scanning
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> scanning → authenticating
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> authenticating → disconnected
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> disconnected → scanning
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> scanning → authenticating
> NetworkManager[775]: <info> (wlan0): supplicant interface state:
> authenticating → disconnected
> … … …
> Activation (wlan0/wireless): association took too long.
>
>
>
> The above repeats for quite a few cycles and it gave up.
>
> I’ve even upgraded NetworkManager (0.9.8.0) & NetworkManager-kde4
> (0.9.0.8) to the latest versions in Factory and the only difference is
> the above attempts lasts longer and it asks me to re-enter my LEAP
> password two-to-three times before it gave up.
>
> I tried downgrading NetworkManager to the version in openSUSE 12.2
> (0.9.4)… bad idea. :
>
> 1) Can anyone who has successfully connect up to Cisco LEAP network
> help me out?
> 2) Can any developer advise what/where are the knobs to tweak this
> timeout so that it can wait a little longer for association?

There are no NM developers here. We are all user volunteers.

> PS: This Cisco LEAP connectivity challenge is not new (from my
> perspective), I find that with almost every new release of openSUSE,
> connectivity with LEAP breaks and it doesn’t get fixed till a later
> update. Further, the error message is always along the lines of
> “association took too long”. Sigh. I know Cisco LEAP is not as
> ubiquitous as WPA or other common wifi authentication mechanism… but I
> would assume that if its working in previous versions, then it should
> continue working in newer versions since the root issue (from my
> perspective, I could be wrong) has to do with timeouts in association
> with the wifi access point… I don’t think the Cisco LEAP standard or
> implementation has changed that frequently. Sorry, just venting here.
> :expressionless:

Well, as long as you can vent, I get to as well. One of my pet peeves is that
some people have strange setups that are broken frequently, yet they never seem
to test the development stages and file bugzilla reports.

Changing the timeout is unlikely to fix the problem. That just happens to be the
condition that NM is detecting due to some failure up the chain. In fact you
showed several cycles of scanning, authentication, and disconection is the log
that you posted.

The file /etc/wpa_supplicant/wpa_supplicant.conf should be the configuration
file for the supplicant. Is that correct? Compare it with the 12.2 version. You
should also check the supplicant log at /var/log/wpa_supplicant.log.

One other thing to try. Assuming that you know how to write a proper supplicant
configuration file (I do not.) for LEAP, does switching from NM to ifup help?

Both wpa_supplicant.conf looks exactly identical and only have two lines:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

However, your suggestion has given me an idea and I checked /etc/NetworkManager/system-connections to find the ESSID and comparing the one in 12.2 and 12.3 yielded some interesting differences.

I will test it tomorrow when I get into the office again to try the LEAP connections. If it works, fingers crossed, I will report back and hope it will help others in the same predicament.

:slight_smile:

In between.

You seem to be rather new here (welcome of course!). There is a hidden, but important feature on the forums posting that we like you to use when posting any computer text like commands and their output, configuration files, etc. That is CODE tags. Allways copy/paste the computer text from the trerminal directly in between CODE tags. You get the CODE tags by clicking on the # button in the toolbar of the post editor.

This will make clear boundaries between “story telling” and computer facts. And it will in many cases prevent the computer text from becoming next to uninterpretable.

Thank you for your cooperation.

Hi Henk, noted and will do so in the future. :slight_smile:

It Worked!!! YES!!! :slight_smile:

The difference I noted in

/etc/NetworkManager/system-connections/<Wireless Name>

between 12.2 and 12.3 has to do with how I defined my wireless security for LEAP. In the GUI, you can specify the wireless security as “LEAP” (from drop-down box) OR “WPA/WPA2 Enterprise” followed by setting the Authentication to “LEAP”.

The latter works while the former doesn’t. Its hard to describe without screenshots here. I’ll be blogging about this later and will come back here to provide the link.

So happy my wifi is working at the office. Yay!

And thanks for reporting back. That may help others.

As promised, here’s the link to my blog on how I resolved this issue with screenshots.

Selling Free Software for a Living: My openSUSE 12 Journal 13: NetworkManager Config for Cisco LEAP Wireless