CIFS share failed to mount, stopped working.

All the sudden our working CIFS share mounted on leap 15.2 stopped working.

I have tried about every mount command using different vers=3.0, 2.0, 1.0…

Oh, and I have tried every version of sec=

I do not control the cifs shares and they did a data migration. The problem is they cannot figure it out

SYSLOGSRV01P:/home/slgadmin # mount -v -t cifs //10.117.16.13/sysstore /mnt/fileservfs01 -o username=svc.syslog,domain=xxx.xxxxx.xxx
Password for svc.syslog@//10.117.16.13/sysstore: ************************
mount.cifs kernel mount options: ip=10.117.16.13,unc=\10.117.16.13\sysstore,user=svc.syslog,domain=xxx.xxx.xxx,pass=********
mount error(2): No such file or directory

What am I missing, this is so simple? I can reach it through windows of course…

I am not a complete novice, I think is it some security they added when they migrated the share.

Thank you,

mib

I think it says this is missing >>>> /mnt/fileservfs01

I wish, not only is there a directory called /mnt/fileservfs01 I set it to 777, all of it. At this point I do not even care about security.

Get it to work and secure it :slight_smile:

Thanks,

mark

Try adding

sec=ntlmssp

to the mount parameters. You’ll need vers=3.0 with this one as well.

Yes, fine, but, which SMB protocol version with which NTLM password hashing variant?

  • Please be aware that, what may have happened is that the Windows Servers are now SMB3 only – no CIFS, anymore …
  • You may have to use the “vers=3” value to allow the negotiation of all possible SMBv3 protocols …

Which verbose messages do you get when you use the parameter order specified in the “mount.cifs” man page?

mount -t cifs //server/share /mnt --verbose -o user=username,vers=3
  • Please note that, Linux Kernels after v3.8 use “sec=ntlmssp” by default.

On the other hand, there’s this StackExchange article: <can not use mount.cifs: mount error(2): No such file or directory - Unix & Linux Stack Exchange.

  • You may have to use “ver=default”, (SMBv2.??) depending on the Windows versions running on the SMB servers …

[HR][/HR]By the way, giving the “write” privilege to “other” and “group” on ‘/mnt/’ directories isn’t needed – despite the “mount error(2): No such file or directory” error raised by “mount.cifs” …

Thank you, I guess sometime it just take someone else to take a look.

I added the FQDN and it worked.

Jul 31 08:05:13 SYSLOGSRV01P kernel: CIFS: Attempting to mount //10.117.16.13/sysstore
Jul 31 08:05:13 SYSLOGSRV01P kernel: CIFS VFS: BAD_NETWORK_NAME: \10.117.16.13\sysstore
Jul 31 08:05:13 SYSLOGSRV01P kernel: CIFS VFS: cifs_mount failed w/return code = -2

mib