CIFS enable in RunLeve gives error: /etc/init.d/cifs a start returned 6 (program is not configured)

Hi,

I have just installed openSUSE-11.4 the 32bit version. I tried to follow this tutorial to create a share on a local disk on the Linux machine. that will be able to be shared by windows machines on a network:

Network File-sharing Tutorial video tutorial - Using Samba to Share Network Files and Printers - Learn: SUSE, yast, software, linux, web, shared, windows, browser, notes, available, settings, systems, files, making, tutorials, share, sharing, service

When I get to the part where it says to Enable smbfs in the System Services Runlevel (I understand this has been replaced by cifs so select cifs and click the enable button and it gives the error /etc/init.d/cifs a start returned 6 (program is not configured)

How can I get this part of the tutorial to work please?

Thank you.

Our SAMBA manual is here: openSUSE SuSE Linux HOWTOs and Tutorials by Swerdna

On Mon June 27 2011 12:27 pm, hcvv wrote:

>
> Our SAMBA manual is here: ‘openSUSE SuSE Linux HOWTOs and Tutorials by
> Swerdna’ (http://opensuse.swerdna.org/index.html)
>
>
wrreisen;

In addition to hcvv’s post. Note that there is a “bug” in apparmor that keeps
smbd and nmbd from running. Go to:
YaST->Novell AppArmor -> AppArmor Control Panel -> Set Profile Modes

Set both usr.sbin.smbd and usr.sbin.nmbd to “Complain” rather than “Enforce”

P. V.
“We’re all in this together, I’m pulling for you.” Red Green

And-------------

If you still get the error: IIRC setting cifs daemon to “enabled” might give an asterisked result until an actual cifs mount is coded into fstab (or into cifstab).