Chromium window has no icon (11.4 GNOME)

I installed Chromium from the 11.4 Contrib repository, but it doesn’t show the icon in the GNOME panel. The icon shows up fine in the applications menu, but not on the open application itself.

Any ideas? =/

I had a similar problem with KDE but only in one user. I solved it by providing an icon in /home to which it could link; in the other users, the link to the system icon worked fine.

Any idea why? If possible, I would like to solve the problem rather than create a workaround.

None whatsover; I tried all sorts of things to resolve the problem before adopting the workaround. So if someone else can come up with an explanation, I shall also be interested.

Hi
Can you try running;


gtk-update-icon-cache --quiet --force "/usr/share/icons/hicolor"

Hi,

Malcolm brought this into my attention and I’ve found and located the problem. This happens because the maintainer of Chromium most likely uses KDE and is not placing the icons on one of the standard paths which in this case should be the ‘hicolor-icon-theme’ and not the Oxygen icon theme.

For a quick test, if you select the Oxygen icon theme, you will see that the icons display properly. This is a packaging issue and I’ve opened a bug report (bnc#705223) for this. If this doesn’t see solution within the next days, I’ll modify the package and submit it, nevertheless it it’s the maintainer’s call to accept or deny it (though I don’t see why he would deny it).

Thanks for bringing this issue into our concern and help making openSUSE a better experience for everyone.

NM

I noticed that it put the icons into /usr/share/oxygen, but it also had one in /usr/share/pixmaps. Does this confirm that pixmaps is deprecated in favor of hicolor?

Thanks for the speedy bug report, but if I myself had submitted it, I probably wouldn’t have labeled it as critical. =)

I believe that the correct order for the icons is:

  1. hicolor
  2. XDG
  3. Pixmaps (considered deprecated by many).

I know there’s on in pixmaps, but I’ve made some changes in the package already and as I’m writing this a test package is building. So once I get to know if it fixes it, I’ll submit it to oS:11.4:Contrib and oS:Factory:Contrib.

What’s the bug ID from your bug report?

NM