Chromium will not start after updates

This morning, I installed 3 updates which included

openSUSE Security Update: Security update for Chromium

Announcement ID: openSUSE-SU-2015:1287-1
Rating: important
References: #939077

There were also two updates for java.

After the updates, Chromium will not start. The little icon bounces beside the cursor for a while and the goes away. Here is some of my system information.

From Yast:

||Alternate Version|Installed Version|
|Build Time:|Thu 23 Jul 2015 04:42:25 AM ICT|Thu 23 Jul 2015 04:42:25 AM ICT|
|Install Time:||Mon 27 Jul 2015 04:50:50 AM ICT|
|Package Group:|Productivity/Networking/Web/Browsers|Productivity/Networking/Web/Browsers|
|License:|BSD-3-Clause and LGPL-2.1+|BSD-3-Clause and LGPL-2.1+|
|Installed Size:|199.6 MiB|199.6 MiB|
|Download Size:|51.6 MiB|0 B|
|Distribution:||openSUSE 13.2|
|Build Host:|||
|Source Package:|chromium-44.0.2403.89-38.1|chromium-44.0.2403.89-38.1|
|Media No.:|0|0|

chromium-ffmpeg has some information in red type.

||Alternate Version|Installed Version|
|Build Time:|Fri 24 Jul 2015 04:30:24 PM ICT|Thu 25 Jun 2015 02:50:23 AM ICT|
|Install Time:||Sun 19 Jul 2015 08:58:14 AM ICT|
|Package Group:|Productivity/Networking/Web/Browsers|Productivity/Networking/Web/Browsers|
|License:|BSD-3-Clause and LGPL-2.1+|BSD-3-Clause and LGPL-2.1+|
|Installed Size:|2.5 MiB|2.2 MiB|
|Download Size:|852.8 KiB|0 B|
|Distribution:||Essentials / openSUSE_13.2|
|Build Host:|||
|Source Package:|chromium-43.0.2357.130-1.2|chromium-43.0.2357.130-5.1|
|Media No.:|0|0|

In the ‘package’ window in Yast, the altenate and installed versions are in red and the installed seems to be newer than the alternate.

From lsb_release -a

LSB Version:    n/aDistributor ID: openSUSE project
Description:    openSUSE 13.2 (Harlequin) (x86_64)
Release:        13.2
Codename:       Harlequin

from lscpu

Architecture:          x86_64CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 69
Model name:            Intel(R) Core(TM) i3-4005U CPU @ 1.70GHz
Stepping:              1
CPU MHz:               1700.398
CPU max MHz:           1700.0000
CPU min MHz:           800.0000
BogoMIPS:              3391.97
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              3072K
NUMA node0 CPU(s):     0-3

and from zypper lr -d

#  | Alias                                          | Name                                           | Enabled | GPG Check | Refresh | Priority | Type     | URI                                 | Service
 1 | Downloads_1                              | Downloads                                   | No         | ----               | Yes     |   99     | plaindir | dir:///home/mike/Downloads                                                      |        
 2 | | Main Repository (NON-OSS)          | Yes       | ( p) Yes       | Yes     |   99     | yast2    |                    |        
 3 |       | Main Repository (OSS)                  | Yes        | ( p) Yes       | Yes     |   99     | yast2    |                        |        
 4 | home:sandrick:13.2                    | home:sandrick:13.2                       | No          | ----               | Yes     |   99     | rpm-md   |   |        
 5 | musescore2                              | musescore2                                  | Yes        | (r ) Yes        | Yes     |   99     | rpm-md   | |        
 6 | openSUSE-13.2-0                       | openSUSE-13.2-0                          | No          | ----               | No      |   99     | yast2      | cd:///?devices=/dev/disk/by-id/ata-hp_DVDRW_GUB0N_M53F3N93555                   |        
 7 | packmanEssentials                     | packmanEssentials                        | Yes        | (r ) Yes        | Yes     |   99     | rpm-md   |        |        
 8 | packmanMultimedia                    | packmanMultimedia                       | Yes        | (r ) Yes        | Yes     |   99     | rpm-md   |        |        
 9 | repo-debug                                | openSUSE-13.2-Debug                  | No          | ----               | Yes     |   99     | NONE     |                  |        
10 | repo-debug-update                    | openSUSE-13.2-Update-Debug       | No          | ----               | Yes     |   99     | NONE     |                                 |        
11 | repo-debug-update-non-oss| openSUSE-13.2-Update-Debug-Non-Oss | No         | ----               | Yes     |   99     | NONE     |                         |        
12 | repo-source                              | openSUSE-13.2-Source                   | No         | ----               | Yes     |   99     | NONE     |                 |        
13 | repo-update                              | openSUSE-13.2-Update                   | Yes        | (r ) Yes        | Yes     |   99     | rpm-md   |                                       |        
14 | repo-update-non-oss                 | openSUSE-13.2-Update-Non-Oss     | Yes        | ( p) Yes       | Yes     |   99     | rpm-md   |                               |        

I’m thinking that chromium-ffmpeg may be the problem but it seems like a bad idea to go back to an older version. Any help would be appreciated.

I don’t use chromium
but from the version numbers it seams packman is lagging with chromium-ffmpeg, chromium has been updated to version 44 but chromium-ffmpeg is still at 43, what to do?
wait a few hours or so until packman updates chromiuim-ffmpeg or downgrade chromium to version 43?
ps. what’s the output when you try to run chromium from a console?

you could try and force install chromium-ffmpeg-beta that’s at #44 but you’d better wait a few hours there will be an updated soon.

ps how do you install updates because chromium should not have updated itself without a corresponding ffmpeg package maybe this is a bugzilla moment?

I had not installed that update, as I expected problems.

After seeing your post, I installed. And, indeed, there were problems.

So I installed “chromium-ffmpegsumo” (to replace “chromium-ffmpeg”). And then chromium worked, though some of the multimedia support is probably missing.

What has happened, is that chromium was updated, but the companion chromium-ffmpeg (on packman) has not yet been updated to the same level. When that is updated, I can reinstall “chromium-ffmpeg”.

I hope that helps.

shouldn’t zypper (or yast) do this automatically if nothing provides chromium-ffmpeg-44 aether replace chromium-ffmpeg with chromium-ffmpegsumo, do not update chromium or ignore dependencies, that’s how opensuse handle’s updates, I remember a few months ago there was an update to qt5 but because of version incompatibility (with lxqt) I was given the option do not update or update at your own risk (lxqt didn’t run with that version of Qt) that’s why I said a bugzilla moment, if an update can’t satisfy dependencies show a warning do not update and brake the system.

I think this is because of the awkward arrangement, with some of chromium coming from packman and some coming from the OSS repo. So chromium dependencies can be met by either chromium-ffmpeg or by chromium-ffmpegsumo. But the dependencies cannot specify a particular version in a way that would tie opensuse to the unofficial packman repo (probably on lawyer’s advice).

Thanks a million

Chromium is up and running. Is there a box to check somewhere to label the thread ‘solved’ or something like that?

You saying that your are satisfied (as you did) is enough.

I’d like to say that this is a partial fix as chromium-ffmpegsumo is not as feature complete as chromium-ffmpeg, it does not have h264, aac or mp3 support so a lot of html5 content will not work (mp4 video’s will not play), ffmpegsumo only supports vp8(vp9) video and ogg audio or better known as webm.
If you need mp4 support downgrade or use firefox or wait a few days for packman to update chromium-ffmpeg.

I notice that “chromium-ffmpeg” has been updated in the Packman repo (for opensuse 13.2).

So I reinstalled “chromium-ffmpeg” to replace “chromium-ffmpegsumo”. And all now seems to work well.

Caught this issue earlier today with latest Tumbleweed snapshot where Packman updated to a chromium-ffmpeg version where that same version for chromium is held up i.e. not yet released in snapshot.

zypper dup gave the file conflict, in ignorance at the time I proceeded and chromium failed to open! On seeing this Factory ML thread, the lights switched on:

I removed the packman version with YaST and it automatically installed the TW version, but still it failed to open (something to do with missing file apparently). I had to remove chromium and chromium-ffmpeg., and re-install chromium then it opened ok.