Chromium crashes

Running Chromium 84.0.4147 on Tumbleweed (20200821) with Plasma
The application keeps crashing within a few seconds of starting.

this is the output I get . . .

failed to open /usr/lib64/dri/
Not using
[8419:8419:0823/] InitializeSandbox() called with multiple threads in process gpu-process.
tcmalloc: large alloc 1708662784 bytes == 0x2b14f9e6d000 @  0x56536b490174 0x56536b490358 0x565365d66220 0x565365d8152a 0x56536adfacef 0x565365db33a7 0x5653676052bd 0x5653676057c8 0x565367605be9 0x565367536386 0x565363d33ef1 0x565363d4247f 0x565363b62256 0x565365e4779c 0x565365e8c487 0x565365e84b30 0x565365e88b7d 0x565365e41f89 0x565363efe524 0x565363efe5ac 0x565365e5100e 0x565365e73ad3 0x7fbfd8111eaa
Received signal 11 SEGV_MAPERR 7ffe27e87008
#0 0x565365d7f931 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#1 0x7fbfd811d260 (/lib64/
#2 0x7fbfd415f344 __memcpy_ssse3
#3 0x56536adfad09 std::__cxx11::basic_string<>::_M_construct<>()
#4 0x565365db33a7 base::Value::Value()
#5 0x5653676052bd cast_channel::(anonymous namespace)::CreateKeepAliveMessage()
#6 0x5653676057c8 cast_channel::CastSocketImpl::DoConnectCallback()
#7 0x565367605be9 cast_channel::CastSocketImpl::DoConnectLoop()
#8 0x565367536386 base::internal::Invoker<>::Run()
#9 0x565363d33ef1 base::internal::CancelableCallbackImpl<>::ForwardRepeating<>()
#10 0x565363d4247f base::internal::Invoker<>::Run()
#11 0x565363b62256 base::internal::Invoker<>::RunOnce()
#12 0x565365e4779c base::TaskAnnotator::RunTask()
#13 0x565365e8c487 base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::DoWork()
#14 0x565365e84b30 base::MessagePumpLibevent::Run()
#15 0x565365e88b7d base::sequence_manager::internal::ThreadControllerWithMessagePumpImpl::Run()
#16 0x565365e41f89 base::RunLoop::Run()
#17 0x565363efe524 content::BrowserProcessSubThread::IOThreadRun()
#18 0x565363efe5ac content::BrowserProcessSubThread::Run()
#19 0x565365e5100e base::Thread::ThreadMain()
#20 0x565365e73ad3 base::(anonymous namespace)::ThreadFunc()
#21 0x7fbfd8111eaa start_thread
#22 0x7fbfd411caff __GI___clone
  r8: 00002b14f9e6d000  r9: 00007ffe27e85420 r10: 00007fbfcab30600 r11: 00007fbfd41b20a0
 r12: 0000000065d8152a r13: 00007ffe27e85410 r14: 00007fbfcab30780 r15: 00007fbfcab30770
  di: 00002b14f9e6eba0  si: 00007ffe27e86fb0  bp: 00007fbfcab306b0  bx: 00007fbfcab306d0
  dx: 0000000065d7f90a  ax: 00002b14f9e6d000  cx: 0000000000080000  sp: 00007fbfcab30658
  ip: 00007fbfd415f344 efl: 0000000000010206 cgf: 002b000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 00007ffe27e87008
[end of stack trace]
Calling _exit(1). Core file will not be generated.

Have tried deleting cache and config files and a forced reinstall but still getting the error.

Chrome 84.0.4147 runs fine
I’m guessing the info I need is in the above output - just not sure what to do with it.

I am no expert with such issues. I just have more questions. Do you use vaapi or a Wayland session? I can remember that this exact message already happened before in those contexts.

I assume there is a video on the page you’re trying to open.
It might be helpful to know if you visit any other web pages with videos on them.

On this specific page,
You can try disabling hardware acceleration before you visit the page.


thanks. I think you have pinted me in the right direction.
I don’t use either vaapi or Wayland . . .but it got me interested to take a look.
Loading up a full wayland session - Chrome (I forget the error) would now not work at all, but Chromium now worked without error.
Returning to an X session and Chromium is now working without problem (and Chrome also works)

no, no video on the page that was loading.
Unable to try any other page because chromium would close before being able to point at another page . . .
but problem solved now anyhow

actually . . . ignore my above post. Problem has reoccurred and I can’t fix it by repeating the above steps.

That sounds really strange. I only have Chrome here to test and it works, it is on an xsession.

I would still try to disable hardware acceleration, just in case, though that would be difficult if Chromium just crashes.

Try to move chromium from .config somewhere else and try to run it with a clean profile.

problem seems to have disappeared and I have done absolutely nothing to fix it (no updates or anything).
I wonder if I have some hardware that is failing that might be causing the issue (pretty old laptop) (but why not same problem on Chrome then?)?