chromium crash on startup

Hello,

Google chromium crash on startup:

[1:1:1212/104847:FATAL:sandbox_bpf.cc(416)] [3:3:1212/104847:FATAL:sandbox_bpf.cc(502)] Check failed: -1 == rv (-1 vs. 354)

I updated a while ago and now does not work.
Opensuse 13.1

How did you update?
In any case, recommend running the following which should update your system to most recent packages of your system and apps installed from repositories

zypper update

I also assume that you’re starting your Chromium manually and not trying some kind of automatic start when the system boots.

TSU

All updated even Flash player.
Just after upgrading is that I have a problem.

Try force re-installing chromium

zypper in -f chromium

TSU

There are reports about similar crashes here:
http://bugzilla.opensuse.org/show_bug.cgi?id=907673
https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1288309.html
http://code.google.com/p/chromium/issues/detail?id=439795&thanks=439795&ts=1417965276

I notice that all of them mention a 32bit system, so this might be 32bit specific.

Yes 32 bit here.

Well, probably you should add a “Me too” to one of the bug reports (you can login on bugzilla.opensuse.org with the same username/password as here), and point out that you have a 32bit CPU as well and this might be a 32bit specific problem.

Yes, I had voted, but now I’ll add a comment.

Luckily my main browser is Firefox (has never failed me:smile:).

Thank you all for your recommendations.

I have the same problem and this is bad. :frowning:

:~> chromium --version
Chromium 39.0.2171.65

does not start. an error

:~> google-chrome --version
Google Chrome 39.0.2171.95

no error

Hello folks.

Does the install of chromium-ffmpegsumo help? Granted that the issue is kind of different.

See this: https://forums.opensuse.org/showthread.php/491282-Chromium-page-crash-on-quot-gmail-com-quot?highlight=gmail+crash

Dave

No, that’s a problem unrelated

If you launch System Activity (Ctrl-Esc), you will see it is loaded in the background, but nothing is on your screen.

In there, kill the process. Downgrade to v38 and it will run again. This is a bug, apparently hitting 32-bit systems.

I also see it on my main machine, in openSUSE 13.1 32-bit, KDE.

In my case, I only use it on rare occasions, so no big deal, I can wait. I use Firefox ESR.

However, this needs to be fixed ASAP because of the Security issues, so add a “me too” to the bug report.

I wonder why chromium isn’t downgraded in the repository until it gets fixed?

Considering the Security risks that are now quite public in it, I would submit that it is much wiser to use an alternative browser in the meantime than it is to actually downgrade to the vulnerable version.

I would only downgrade and run it if it were the only option.

Use Firefox or Konqeuror – or something else – until Chromium is fixed.

The older version is still available. The update repo always keeps the older versions, and there’s always the one from the standard repo as well (the main repos are frozen after the release, updates are only delivered through the update repo).

Click on “Versions” below the package list in YaST->Software Management to install an older version, if you really want to.

Thanks for the info. I’ll give it a try.

I cannot add much to this; just a Me too on 32-bits machine.
In my case I will use firefox until the problem is solved.
Thanks a lot in any case.

… a few days ago, I actually went the extra step and removed Chromium from my systems. Running Firefox on them all, now.

openSUSE kernel updated today and chromium now works fine!