Chrome: Aw, Snap!

Getting increasinig occurrences lately … today almost constantly !!!
http://files.zimpics.org//forum/suse/AwSnap.png

… more often than not F5 refreshes successfully … but not always … has anybody a difinitive explanation/solution??

Would be much appreciative … thanks.

G

Please our crystal balls have run nuts. :frowning:
Which browser(s)? Which Web-site/pages?
Any information at all or do you think we all have the same as you?

Yes … indeed! … well seeing it seems to only happen in Chrome/Chromium while accessing Google links i had imagined it would be specific to google.com and chrome … my signature shows the enviroment … the browsers concerned are Chrome varieties … although i must admit i have not use Firefox much … so maybe it happens there too??

Sites?? hmm … seems to be when i click on a link returned from a google search … but then i have seen it AwSnap me when Chrome initially tries to access my router page at times … but as i said a simple F5 pushes through that.

This phenomemon seems to be happening more frequently lately … dont know if it could be ISP issue … something else running in memory … a Google issue … just would be guessing as am really just a ‘user’ …was hoping it was a common event with a straight forward solution.

Sorry can’t be more specific … but it sure is annoying!!

Thanks G

Of course you can be more specific. And you can gather more information to present to us. People here are glad to help, but the most basic and logical things to do yourself and to present them here is your task. People here are not going to to the obvious.

So try to use Firefox and/or any aother browser (Konqueror e.g.) on the same address to see if the problem is also there.

We can not do anything to reproduce your problem as long as you do not provide us at least with one URL where you have the problem.

hmm … so ‘AwSnap’ also happens with the url: :chrome://settings/: … so i assume it has nothing to do with external environments or events?? Of course F5 refresh completes the task. ??

Personally I have no idea. I do not use Chrome and when you would have told that in your first post here, or even better in the title, I would not have answered to the thread at all.

As a moderator, I try also to teach people how to post questions in a way that support and help can be given in an efficient way (or at all). Your post was barren of almost any real information, thus my request for it.

So wait for Chrome users that may be able to help you (But as the word Chrome is not even in your thread title, the Chrome users may not even open this thread :().

Okay … fair point … pity one cannot edit the title (or can one?).

I think it might be the ISP … or whoever they route through:

mynetfone is the ISP … i have signed up for 25MBits/sec down and 5MBits/sec up … this is the latest snapshot of their supply!

 Traceroute mynetfone.com.autraceroute to www.mynetfone.com.au (125.213.165.3), 30 hops max, 60 byte packets
 1  192.168.19.48 (192.168.19.48)  0.845 ms  0.838 ms  1.141 ms
 2  125.213.167.25 (125.213.167.25)  108.736 ms  109.546 ms  109.547 ms
 3  125.213.167.199 (125.213.167.199)  109.928 ms  110.736 ms  110.739 ms
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

traceroute to www.google.com (216.58.203.100), 30 hops max, 60 byte packets 1  192.168.19.48 (192.168.19.48)  0.900 ms  0.887 ms  1.174 ms
 2  125.213.167.25 (125.213.167.25)  111.965 ms  111.982 ms  111.976 ms
 3  125.213.167.199 (125.213.167.199)  175.945 ms  175.958 ms  175.959 ms
 4  as15169.sydney.pipenetworks.com (218.100.2.97)  114.317 ms  114.324 ms  114.310 ms
 5  108.170.247.65 (108.170.247.65)  114.690 ms  114.667 ms  115.824 ms
 6  209.85.255.165 (209.85.255.165)  115.822 ms 209.85.255.175 (209.85.255.175)  121.438 ms *
 7  syd09s15-in-f4.1e100.net (216.58.203.100)  111.223 ms  110.796 ms  112.797 ms
speedtest.mynetfone.com.au
Last Result:
Download Speed: 3348 kbps (418.5 KB/sec transfer rate)
Upload Speed: 4526 kbps (565.8 KB/sec transfer rate)
Latency: 87 ms
Jitter: 15 ms
04/07/2017, 21:23:46

The Chrome/Chromium “Aw, Snap!” generally means the page was unreachable…
And, indeed a simple evaluation of your traceroutes indicates massive latency.
A fast connection should be <100mx, a somewhat busy connection but still normal might be 100-200ms, and anything larger than that indicates congestion. 500ms might be just slow, but over 1000ms means something is really bad.

Since the largest latency is at your own Gateway Router, you’re probably causing the problem… There may also be a problem further upstream, but you need to resolve your own network’s issues first.

TSU

The aw snap has nothing to do with your network.
I’ve had the same issue and actually it turned out that nproc limit is too low.
Apparently a bug has been submitted already.
https://lists.opensuse.org/opensuse-bugs/2016-11/msg04282.html
As soon as i manually changed this value chrome started working properly.
I’m not sure why devs thought that this limit is ok. Chrome alone with more tabs together with other apps can easily go over that limit and actually i also had issues where apps won’t start up because of nproc limit.
So try and increase the number and see if that resolves the issue.

Okay thanks nosferatu … sounds like a plan!!!

But for me … and others like me … how does one configure this setting??

This is what i found in linits.conf


#*               soft    core            0
#*               hard    rss             10000
#@student        hard    nproc           20
#@faculty        soft    nproc           20
#@faculty        hard    nproc           50
#ftp             hard    nproc           0
#@student        -       maxlogins       4


# harden against fork-bombs*               
hard    nproc           1700
*               soft    nproc           1200
root            hard    nproc           3000
root            soft    nproc           1850

Okay!!

I change my limits /etc/security/limits.conf file to this:

# harden against fork-bombs#
#*               hard    nproc           1700
*               hard    nproc           34000 #set by me 13/07/2017
#*               soft    nproc           1200
*               soft    nproc           24000 #set by me 13/07/2017
root            hard    nproc           3000
root            soft    nproc           1850



and at first sighting the whole system seems to be more ‘snappy’ (excuse the pun!!)

Cant thankyou enough!!

Lets see if it continues :slight_smile:

FYI … just as an aside. You can’t blame me for thinking it was a NetWork issue with this type of ISP performance lol (ongoing i might add!!)

http://files.zimpics.org/forum/suse/MNFSpeedTests.png

UPDATE: Well it has been almost week since i incorporated this suggestion … guess what! … NO MORE ‘Aw, Snap!’

… and not only that for the first time since upgrading to 42.2 the system ‘feels right’!!

Previously mysterious GUI glitches and plasma crashes and frozen windows … all apparently at random! It would be hard to say it is just a coincidence that my system now behaves as one would expect.

Smooth and crisp!!

A BIG thankyou to @nosferatu037 … a real gem this solution!! ;):Olol!

You are most welcome.
Still I’m not certain why this is on by default if someone can explain it would be great?
It took me a while to figure out what the hell was going on.

… and further … i might add that previous to expanding these hard and soft “* nproc” settings i used to experience situations that resembled exactly what the limits are there to protect against … ie . System becomes unresponsive, clicking on anything is ignored, sending shutdown signal ignored … system frozen!! Only solution is to reboot!! This was happening on a not too lengthy frequency … i did not log occurrences … but from memory every 2nd or 3rd day perhaps … with a whole lot of ‘Aw, Snaps’ inbetween i might add!! :frowning:

But since making the changes suggested at [Bug 1012494] New: pam: nproc limit too low - openSUSE Bugs - openSUSE Mailing Lists (as supplied by @nosferatus037)

“So please remove that limit again or set it at least 20 times higher”

… the above behaviour has not returned!!

But being a novice i really have no idea if what i have done is a good or bad thing technically, but it has certainly improved my systems usability.

For sure I will add to this post should my system have a relapse :slight_smile: