Choppy sound with Sony MDR-1RBT Headphones

I’m trying to get my Sony MDR-1RBT headphones to work. They seem to be normally paired over Bluetooth with my computer but the sound becomes choppy over and over again. (It has nothing to do with the headphones themselves since they work fine under windows.)

Any help would be appreciated.

I have same headphones - but I don’t nominally use with bluetooth with openSUSE.

I’m heading off on vacation for over a week and don’t plan to take my headphones with me. (I use a setup of non-blue tooth Bose headphones on the flight).

When I get back in April, I’ll take a look (connect my headphones to the bluetooth on my ultrabook) and see if I observe anything similar. My ultrabook is also running openSUSE-13.2.

Be certain to do all the standard checks for choppy sound - ie ensure volume not turned up so loud you are in distortion … etc …

I spent a long time trying to get my sony bluetooth headphones to work without choppy/stutter problems.
The 2 causes I had were the bluetooth adapter still searching for new devices and the bluetooth adapter itself (a small usb adapter which has been changed)

Thanks both of you for your quick responses!

@oldcpu: I 'll be glad to hear from you again if you have any news regarding this issue. Even more if you have a fix.:smiley:

@topwurth: I’m using the Bluetooth device that’s integrated into my motherboard. I have some adapters also but I have no idea how I could get OpenSUSE to use them (nothing happens when I connect them to the USB port).

It turns out my headsets are not the MDR-1RBT but rather the Sony MBR-10RBT.

They ‘just work’ with bluetooth with my Toshiba Z930 Ultrabook (I am playing them now as I type). Sound quality is very good.

I recommend you look for generic solutions to choppy pulse audio, and not focus on this being with headsets.

Some speculative ideas to try (I found these on the Arch Linux wiki) :

[INDENT]Choppy sound with analog surround sound setup

The low-frequency effects (LFE) channel is not remixed per default. To enable it the following needs to be set in /etc/pulse/daemon.conf :

 /etc/pulse/daemon.conf enable-lfe-remixing = yes

Restart your PC and test.[/INDENT]

and also if the above does not work remove the above and try:

[INDENT]Choppy/distorted sound

This can result from an incorrectly set sample rate. Try the following setting in /etc/pulse/daemon.conf

default-sample-rate = 48000

and restart the PulseAudio server (where simplest way to describe this is to just restart PC (although there are other ways without PC restarting)) .

If one experiences choppy sound in applications using OpenAL, change the sample rate in /etc/openal/alsoft.conf:

frequency = 48000

Likely there is no “alsoft.conf” in /etc/openal and hence this may not be applicable to you.

Setting the PCM volume above 0 dB can cause clipping. Running alsamixer will allow you to see if this is the problem and if so fix it. Note that ALSA may not correctly export the dB information to PulseAudio. Try the following in /etc/pulse/

load-module module-udev-detect ignore_dB=1

and restart the PulseAudio server (ie reboot).[/INDENT]

Also - at the risk of saying something too obvious, a low battery charge in headset will cause choppy audio. Also, having the headsets too far from the computer will also cause choppy audio. I did not mention this earlier as it is so obvious I seriously doubt this is your trouble.

oldcpu thanks for your answer!

The first time I applied all 3 changes you suggested at once and after I rebooted I got an error “could not connect to pulse”. Then I removed the
load-module module-udev-detect ignore_dB=1

from /etc/pulse/ Pulse was working again. The sound during my
short test was choppy but without the distortion like the first time.
This becomes more noticeable with slightly moves and around 2 meters away
from Bluetooth I get no sound. I suppose this is due to the Bluetooth
connection. BTW my Bluetooth mice don’t work nicely either. Like I mentioned before
I use the integrated Bluetooth from my mainboard and although I have tried with
usb adapters I can’t get them work.

The headset is fully charged.

2 meters is very short. With my Sony MDR-10RBT I can go 5 meters from my ultrabook and smartphone. I recall one has a longer range than the other (with this headset) but I can’t currently remember which has the longer range.

To confirm this is not the receiver in the Sony MDR-1RBT, have you tried this with another device and also another OS ? ie try with an Android phone . Or if you have MS-Windows on your PC try also with MS-Windows.

My suspicion is this could be the bluetooth transmission of your PC is not so good. Is this a laptop PC ? If so, what make/model # ? Have you researched to read of the success of other’s with same PC hardware ?

The headset works fine under Windows, I get clear sound even beyond 5 meters. I have a custom build with an Asus P8P67 PRO Rev 1.xx mainboard. I did some research but I couldn’t find something directly related.

This is not a new motherboard.

There are many threads on the internet about users struggling with this hardware and Bluetooth with GNU/Linux. For example:

Unfortunately I have not see one where - cause -effect - solution is clearly laid out.