choosing window manager at login doesn't work any more

I installed a few window managers (gnome, kde, xfce, icewm etc) because I wanted to try them out.

At first it worked, but now I sometimes can’t choose which one to use. No matter what I choose in the session-menu, the last DE is launched. No difference if I try to log out or restart the entire computer.

Normally the last used wm will be marked in the list, and when that is the case I can choose some other, but quite often nothing is marked and then it will always start the last used wm even if I try to change it.

For a while I thought it might have something to do with error messages I got in various situations about .ICEauthority, among other preventing me from logging into KDE. After doing some searching I found that it was just the rights that were set wrong, so I changed it and since then I have not seen any error messages. But maybe it can still be involved in some way?

I also found some threads about making sure DISPLAYMANAGER (if I remember it right) is set to kdm, but it already was when I checked.

I don’t know where else to look, so any suggestions will be appreciated.

(I have openSUSE 11.1)

> I got in various situations about .ICEauthority, among other preventing

let me GUESS that you have, probably more than once, logged into one
or more different window managers as root.

which will typically screw up permissions and ownerships…

the solution is to never log into any Linux GUI (KDE, Gnome, etc) as
root…ever.

instead, visit http://en.opensuse.org/SDB:Login_as_root and learn how
to log in as a regular user, and THEN how to become root when
necessary…*

now, to backtrack and undo any/all damage already done is not
something i know how to do exactly, but i GUESS if you find a GUI you
CAN log into as yourself, and then become root and change all the
file/folder permissions in your /home so that they are both owned by
you and accessible by you, maybe JUST maybe you can recover without
a reinstall and THEN never log into a GUI as root again, ever.

also, i do not know for sure if there is a relationship between your
current inability to change window manager and any past logging in as
root…but, i GUESS they are somehow connected…what i’m saying is,
you might repair all the permissions/etc in your /home and STILL not
be able to switch window managers…

good luck, and have lots of fun learning…

if you would be so kind to return and tell me if my guesses were
correct (both the suspected cause, and cure) i’d much appreciate it…


solo
*

I NEVER logged into the gui as root.

I just found out that my root-partition is packed full, the culprit being a 15G /var/log/zypper.log Dare I delete it, and how do I make sure it doesn’t fill up again?

Thank you for giving your time MultiplePersonality. (I actually recently read another post about logging in as root that must have been from you :slight_smile:

I think I might have mixed “window manager” and “Desktop environment”, but I meant KDE/Gnome/Xfce etc.

spigge wrote:
> I NEVER logged into the gui as root.

ok, YEP a full partition will do what you saw also…Linux HATES full
partitions…

> I just found out that my root-partition is packed full, the culprit
> being a 15G /var/log/zypper.log Dare I delete it, and how do I make
> sure it doesn’t fill up again?

you could delete it (it should be generated again, next time you run
zypper), but it would be better to compress it with your favorite
archiver until you know you need the info therein to help fix
something else…

you could adjust your /etc/logrotate.conf to rotate/compress and then
dump logs, (i dump those over four weeks old) see:

man logrotate


solo

Thanks, I’ll try that in the morning. What do you mean by dump? Is it that logrotate removes the files if they are older than the number of rotations it is supposed to do (rotate 4, for example, deletes the oldest when there is more than 4 files if I got it right)?

I will probably post a suggestion for config-file when I have come up with one. I would appreciate if you would have a look at it then. Some of the man-page went over my head.

spigge wrote:
> Thanks, I’ll try that in the morning. What do you mean by dump? Is it
> that logrotate removes the files if they are older than the number of
> rotations it is supposed to do (rotate 4, for example, deletes the
> oldest when there is more than 4 files if I got it right)?

right, it keeps logs for only 4 weeks, and deletes the fifths week,
ever week…

> I will probably post a suggestion for config-file when I have come up
> with one. I would appreciate if you would have a look at it then. Some
> of the man-page went over my head.

over mine too…i just looked and for the first time (in 10.3) see
that in fact mine is NOT deleting old logs…surprised, i see that my
/etc/logrotate.conf looks NOTHING like what is given as an example in
“man logrotate”…

i don’t remember, but i can only assume that i saved my logrotate.conf
from a previous install and just stuck it in /etc

so, i have a mess of old logs–BUT none approach the 15 gig file you
have/had…and, it IS compressing old the old logs…and i still have
plenty of space on / so i’m not gonng try to “fix it” as i figure i’ll
do a fresh install with either openSUSE 11.2 or SLED 11…


duo

Today the zypper.log was already compressed, so I didn’t have to do anything. I checked the logrotate.conf and logrotate.d/zypper.lr. From what I can understand the settings should be alright, but it doesn’t seem to follow them… The zypper.lr is set to compress zypper.log if size exceeds 10M which it obviously doesn’t, and (less important but still weird) the compressed files are gzipped even if compresscmd is set to bzip2.

The files look like this:

logrotate.conf (not showing entries for wtmp and btmp as I assume them irrelevant)

# rotate log files weekly
weekly

# keep 4 weeks worth of backlogs
rotate 4

# create new (empty) log files after rotating old ones
create

# use date as a suffix of the rotated file
dateext

# uncomment this if you want your log files compressed
#compress

# RPM packages drop log rotation information into this directory
include /etc/logrotate.d

# comment these to switch compression to use gzip or another
# compression scheme
compresscmd /usr/bin/bzip2
uncompresscmd /usr/bin/bunzip2

# former versions had to have the compressext set accordingly
#compressext .bz2

and logrotate.d/zypper.lr

/var/log/zypper.log {
    compress
    dateext
    notifempty
    missingok
    nocreate

    maxage 60
    rotate 99
    size 10M
}

The huge logfile, now autocompressed, contained entries for the last week.

Any ideas?

> Any ideas?

because my logrotate.conf is exactly the same as yours…and, i’m
mystified why it does not delete logs more than four weeks old…

anyone??


duo