Chocolate Doom is running but the image is squashed

Please take a look at the screenshots:

There are no errors reported in the cmd line except a MIDI-related warning.

razvan@linux-k5ue:~> chocolate-doom
Chocolate Doom 3.0.0
Z_Init: Init zone memory allocation daemon.
zone memory: 0x7f4fa85ec010, 1000000 allocated for zone
Using /home/razvan/.local/share/chocolate-doom/ for configuration and saves
V_Init: allocate screens.
M_LoadDefaults: Load system defaults.
saving config in /home/razvan/.local/share/chocolate-doom/default.cfg
W_Init: Init WADfiles.
adding /usr/share/doom/freedoom2.wad

                       Freedoom: Phase 2

Chocolate Doom is free software, covered by the GNU General Public
License. There is NO warranty; not even for MERCHANTABILITY or FITNESS
FOR A PARTICULAR PURPOSE. You are welcome to change and distribute
copies under certain conditions. See the source for more information.

WARNING: You are playing using one of the Freedoom IWAD
files, which might not work in this port. See this page
for more information on how to play using Freedoom:

I_Init: Setting up machine state.
Failed to get I/O port permissions for 0x388: Operation not permitted
You may need to run the program as root in order
to acquire I/O port permissions for OPL MIDI playback.
OPL_Init: Using driver ‘SDL’.
NET_Init: Init network subsystem.
M_Init: Init miscellaneous info.
R_Init: Init DOOM refresh daemon - …]
P_Init: Init Playloop state.
S_Init: Setting up sound.
D_CheckNetGame: Checking network game status.
startskill 2 deathmatch: 0 startmap: 1 startepisode: 1
player 1 of 1 (1 nodes)
Emulating the behavior of the ‘Doom 1.9’ executable.
HU_Init: Setting up heads up display.
ST_Init: Init status bar.

I checked the resolutions, aspect ratio page, run the setup (chocolate-doom-setup). Nothing seems to fix this. Any ideas?