chessboard instead of desktop

so I finally managed to install openSuse 12.2 on my laptop ( I experienced some problems installing it) and the first time after installation I booted, everything works fine; it configures everything etc, I worked a bit in it, and then it got late so I shutted it down (the normal way with the power off button in the ‘favourites’ menu)
so today I turn my laptop on again, it boots but instead of showing my desktop it shows a chessboard like screen and a little green square instead of my mouse…
I assume that this is my fault doing something wrong but I can’t think of anything…
is this a commong bug? and does anyone know how to fix this?
thanks in advance

Would you be able to provide some more detail? What kind of laptop, graphics card and desktop (KDE, Gnome, XFCE, etc)? It will be a lot easier for people to trouble shoot your situation if you provide this information. And I wouldn’t assume it’s your fault. Give yourself some credit! :slight_smile:

well if I may believe my teacher Linux, everything that goes wrong on Linux is my fault…
I am using a Dell Latitude D830
2GB RAM 2.0 GHertz clockspeed
NVIDIA graphic card
KDE openSuse 12.2

the problem itself: it boots perfectly the first time after installation, when the cofigs are done
but when I shut down after that and start openSuse again, the desktop is completely misformed. sometimes I seem to find parts of screens that were open the first time I booted (Eclipse & Chromium and shutdown) but thats mainly it. unfortunately I can’t provide screenshots (for obvious reasons) but I really want to use openSuse :frowning:

Unless you designed and programmed everything yourself this is a bit harsh…

I think this may be a Nvidia driver issue. Does it look OK when you boot with the Failsafe option? This is the 2nd entry in the GRUB startup menu.

If it boots OK and you have internet access I would install the Nvidia Graphics drivers. Several ways are described here: SDB:NVIDIA drivers - openSUSE

The easy way should work fine. After the process if completed see if you can boot normally then.

I tried the failsave option, but at certain point it doesn’t continue loading. I believe it stopped after ‘loading … firewall done’ or something like that :
I’ll try it again and let you know the results, thanks

although I have another question, why does it looks fine the first time and the second time not?

Am 22.09.2012 14:56, schrieb Jir0:
> NVIDIA graphic card
Which one do you use exactly, it may help if you install the proprietary
nvidia driver (that depends on your model). As a preliminary information
http://en.opensuse.org/SDB:NVIDIA_drivers#Easy_way_to_get_NVIDIA_drivers


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I don’t know the excact reason but I belief it has to do with what driver is loaded during the installation. If you have noticed, it actually never fully reboots when the configuration is done. When you do a cold-start (you turn the computer on), it loads whatever driver it thinks you should use.

Installation of the proprietary NVidia drivers should resolve this matter. Try the following if you cannot load a desktop:

Login to “command line Linux” by following this How-To -> How to Start openSUSE 12.2 with Grub 2 into Run Level 3 - Blogs - openSUSE Forums

Make sure you have internet access for the next bit. A network cable connected to your router for your internet connection may work better. if not you can get use your WiFi from the command line by using:

sudo ifup wlan0 <networkname here>

I think the above command should work. I don’t have a Linux machine near me to try. If it doesn’t work do the following:

su -
<enter root password>
ifup wlan0 <networkname here>

Ones you have internet access run the Zypper procedure as root. It is described in the Zypper section on the page I gave earlier: SDB:NVIDIA drivers - openSUSE

I managed to fix it, although I don’t really know how and I’m not sure if it’s stable. I’ll try to find out more and post the results here. thanks to everyone who took his time to help me out!

Am 22.09.2012 18:36, schrieb Jir0:
> I managed to fix it, although I don’t really know how and I’m not sure
> if it’s stable. I’ll try to find out more and post the results here.
> thanks to everyone who took his time to help me out!

Did you fix it with the proprietary nvidia driver? If so you can at
least make sure that it is installed and in use by running


glxinfo | grep -i opengl

in a terminal and post the output.


PC: oS 12.2 x86_64 | i7-2600@3.40GHz | 16GB | KDE 4.8.4 | GeForce GT 420
ThinkPad E320: oS 12.2 x86_64 | i3@2.30GHz | 8GB | KDE 4.9.1 | HD 3000
eCAFE 800: oS 12.2 i586 | AMD Geode LX 800@500MHz | 512MB | KDE 3.5.10

I managed to make it work the first (and instable time) by logging of with a hotkey. then I grabbed my chance and installed the NVidia drivers you gave me and now it works perfectly. I saw the NVidia logo flashin by at boot so I’m pretty sure it’s installed. everything works now, so my thank is great!

Glad to here! Enjoy!!