Cherrytree not starting

I saw a demonstration of Cherrytree amd thought it would be quite useful for me. I installed it and tried to start it. It would not start. So, I opened a terminal and tried to start it and got an import error:

bart@MSI-5960:~> cherrytree
Traceback (most recent call last):
  File "/usr/bin/cherrytree", line 78, in <module>
  File "/usr/bin/cherrytree", line 49, in f_main
    import main
  File "/usr/share/cherrytree/modules/", line 24, in <module>
    import dbus
ImportError: No module named dbus

I looked for dbus

bart@MSI-5960:~> su -
MSI-5960:~ # find / -name dbus
find: ‘/run/user/1000/doc’: Permission denied
find: ‘/run/user/1000/gvfs’: Permission denied
find: ‘/proc/2533/task/2533/net’: Invalid argument
find: ‘/proc/2533/net’: Invalid argument
find: ‘/mnt/Server’: Permission denied
MSI-5960:~ #

Line 24 in /usr/share/cherrytree/modules/ simply says “import dbus”

What am I missing?


Is python36-dbus-python installed?

I would say not. I did a find and it’s not shown. I used yast -> softwaremanagement -> search and got the no results message.

Is it part of a package?

I did the install using yast and thought all the requirements would have been included.


The Cherrytree version in Leap is unsupported, I maintain the newer version in Tumbleweed…

Install python-dbus-python and all should be good.

I tried that and no joy Same error message :frowning:

It seems to be a great utility, I’m thinking I could really use it.

Is there a way to install the tumbleweed version in leap?


I tested the Leap 15.3 version here and all working fine after installing that python package…

Nope, the newer version is completely different build process and not supported in Leap :frowning:

Using yast, and searching for python-dbus-python, the package is shown as python-dbus-python-common-devel. Is that is the one you are recommending I install? (I did).

If I understand what I’m seeing in the error message, cherrytree is looking for a .py module called dbus. There is no module called in /usr/share/cherrytree/modules/.

Using find I see only these three items:

MSI-5960:~ # find / -name

It would seem I should have /usr/lib/python3.6/site-packages/cherrytree/ or a generic somewhere on my system.

Something has to be different between my system and yours.

It’s python2 not python3, python2-dbus-python when I installed it selected capabilities and installed…

AHA! Now it works! I just searched for python-dbus-python and installed it. That little 2 was all it took.

Thank you so much!