cherrytree crashes

Cherrytree (notes - taking app) crashes at start. I can see the icon on the task bar for 1 or 2 seconds and the application closes. I just made a fresh install of Tumbleweed on a new laptop. In another lap, with Tumbleweed too, I had no problem installing and running Cherrytree and I assume that there are some files missing… Can you help me? Thanks

Open cherrytree from Konsole. The resulting messages may suggest what is going wrong.

You might also want to tell us which desktop environment, and Xorg or Wayland.


it is Xorg

This is what I obtain in command line:

$ cherrytree
Traceback (most recent call last):
  File "/usr/bin/cherrytree", line 78, in <module>
  File "/usr/bin/cherrytree", line 49, in f_main
    import main
  File "/usr/share/cherrytree/modules/", line 42, in <module>
    import cons, core
  File "/usr/share/cherrytree/modules/", line 42, in <module>
    import machines
  File "/usr/share/cherrytree/modules/", line 23, in <module>
    import xml.dom.minidom
ImportError: No module named xml.dom.minidom

I donot know what these messages mean. Could you tell me?

Since it’s still built with python2 is python2-libxml2 installed?


It wasn’t. I just installed it but still the same behavior :(. Is there something else to install?
Thank you for your reply.

I have no experience with using cherrytree, but you might consider directing your question(s) to the developers perhaps

No issues here (Gnome and Xorg), I have however sent an update through as well.


Can you create a test user, login and see if the issue duplicates.

Just checked, it’s ‘python-xml’ that is needed. Saw the same as the OP, installing python-xml fixed it.

I’m guessing something else pulled it in here, added to spec file requires and re-submitted the update :wink:



Now it’s working!
Thank you very much for your support.
Thanks to all of you who gave me some advice.
Cheers, :slight_smile: