Checkspell in other languages for LibreOffice 4.1.3


It seems that check speller does not work correctly. It is not possible to specify which language should be checked *during *spell check. If you click on <Spelling and Grammar …>, you can notice that Text Language is not specified, and it is not possible to specify it because check speller closes immediately after “completing its task.” Moreover, if one tries to specify which language should be checked via Tools → Language → For all Text/Paragraph/Section, it does not have effect although there is option to choose various languages. Only spell check that works is for English (it seems that it is only properly installed). Do other have this problem?

I have also noticed that there is no available language tool for Norwegian bokmål, i.e. it is missing libreoffice-languagetool-nb in the list of packages under YaST2 Software Managment. To whom I can notify that it is missing?

Best regards,


Have you checked for dictionaries in Yast?

Or with zypper se :slight_smile:

paulparker@linux-30s5:~> zypper se libreoffice- | grep -i 'norweg'
  | libreoffice-help-nb                        | Norwegian Bokmaal Help Localization for LibreOffice      | package   
  | libreoffice-l10n-nb                        | Norwegian Bokmaal Localization Files for LibreOffice     | package   
  | libreoffice-l10n-nn                        | Norwegian Nynorsk Localization Files for LibreOffice     | package   
  | libreoffice-thesaurus-nb                   | Norwegian Bokmaal Thesaurus Dictionary for LibreOffice   | package   
paulparker@linux-30s5:~> zypper se -d 'norwegian' 

Deleted results for second command, as longer results.

To install you need log in as root or using **sudo <commands> **

It is very easy to specify which language should be checked in a document. The first time you insert a word in a different language from the language you have specified in Tools>Options>Language, highlight the word and use Format>Character>Font to set the language of that word. The next time you want to add another word in that language, highlight the word and click on the language tab at the bottom of the screen which will show a pop-up list of the languages you are currently using; you only need to click on the language to set the word to the desired language.

Alternatively, if you are inserting a lengthy passage in another language, use the pop-up to specify the language and then carry on typing.

If you select a language for which you do not have a dictionary installed, LibreOffice will simply ignore the word. This is useful if you have some obscure foreign or technical words in a document; just give them a language like Latin for which you probably don’t have a dictionary installed and LibreOffice will ignore them.

Yes, you need to install the appropriate libreoffice-languagetool and libreoffice-thesaurus files available for your language …