checking 1 TB ext3 disk takes 30 minutes

After several reboot/boots openSuse 11.0 wilt check the filesystems. I’ve got one 1TB, two 500GB and two 80GB (raid0) disks. The two 500GB and one 1TB are ext3, the raid0 is xfs.

The two 500GB are fast checked but the 1TB disk takes 30 minutes to check.
Why is this happend and can I speedup or disable this process?

It’s a problem when the PC boot for a recording with MythTV.

You can change the automatic filesystem check settings (number of mounts and number of days after automatic check) with “tune2fs” as root.
See “man tune2fs” for details.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

You can change this check with ‘tune2fs’ as I recall but it’s there for
a reason and is probably left enabled. Are you rebooting often for a
reason? You could also change that drive to xfs or reiserfs, neither of
which do this as I recall. I run xfs on all my machines full-time and
have been happy with it (used to use reiserfs for everything).

Good luck.

assem046 wrote:
> After several reboot/boots openSuse 11.0 wilt check the filesystems.
> I’ve got one 1TB, two 500GB and two 80GB (raid0) disks. The two 500GB
> and one 1TB are ext3, the raid0 is xfs.
>
> The two 500GB are fast checked but the 1TB disk takes 30 minutes to
> check.
> Why is this happend and can I speedup or disable this process?
>
> It’s a problem when the PC boot for a recording with MythTV.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJLUda3s42bA80+9kRAh2mAJ0VuvNHoobD8fsUQ6bVAlqXJHyp1ACeLvuv
E8AjPk0CwphvKTCYQRoHeeE=
=el9u
-----END PGP SIGNATURE-----

Ok, I will change to xfs when my second 1TB disk arrives.
I used ext3 because of the use with Windows but I don’t use windows anymore.

Thanks.