Checkerboard problem solved, now Compiz?!

I recently updated my systems packages to newer versions, if available (with no dependency issues)(suse 11/kde 4.1).

However, after i logged back in I got the “checkerboard” problem (KDE 4.1.1 Upadate Checkerboard Problem - Page 2 - openSUSE Forums).

After adding the qt44 repo and updating that problem was fixed, however…I have a new problem:

Compiz is not started (even though my ccsm settings remain the same). I tried going to session manger but there is no longer an option to change the window manager there…

If I try to “enable desktop effects” under settings (even though I dont use those effects, I use compiz effects) I get the message:

"Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type."

So, long story short…I can’t get compiz working again. Am I missing something simple or is this related to the reason the checkboard problem has come up?

Maybe the window manager was reset to default and not compiz? I dont know how to change that anymore since the option isnt under sessions anymore…

Any help would be appriciated! :slight_smile:

Ok, so I found the window manager, duh, its under default apps under settings. Ok, So compiz is selected…but not running…

If i click configure, it says running the config tool failed.

anyone? could use some help here…

I don’t use KDE, but do use compiz, I wonder if you tried deleting
compiz and re-installing? Else maybe update compiz from the X11

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2:38, 1 user, load average: 0.04, 0.03, 0.00
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12

Well with the latest everything from a yast update, kwin doesn’t work with 4.1.x factory. Compiz window manager works however effects and window decorations do not work. :frowning:

For me running xgl and fglrx driver the kwin manager crashes my X server. :frowning: So it is that or no gui.

I switched the window manager to say ICEwm and I get my window decorations, no compiz of course and doesn’t play as nice but it works.