Check USB stick fail


I downloaded the .iso file for DVD/USB stick from the download page and checked the sha256. Matches, this is OK.
I installed it few time using SUSE Studio ImageWriter and DD as describe in the page
on 2 different USB sticks. I plugged it in 2 different computers and did "Check installation media"

I every time got the error "This is not an opensuse 15.0 media"

Looks like there is a bug

Maybe you did it correct, but we are unable to check that because you do not show what you did. For at least the dd method that would be easy to copy/paste here.

OTOH, you do not say so, but by what follows I come to the conclusion that you can boot from it. And it then even knows it should be 15.0 medium (well, it seems that it thinks media is singular, but is that worth a bug report?).

What when you start the installation?

As root

dd if=/home/user/Downloads/openSUSE-Leap-15.0-DVD-x86_64.iso of=/dev/sdf bs=4M status=progress && sync

I tried to install a laptop, full install on previous Fedora.
I went to the expert menu to format the HDD and set partitions; I know the process, this is the 4th computer I install with previous Leap (42.1, 42.3).

After removing old partitions, I had an error message, had to exit from the install.

I don’t know if this is linked to the above error.
I’ll try again later and let you know

Then you have a fine download.

Your USB is almost certainly fine. The media check only works for CD and DVD devices. It always reports a fail for a USB.

The reason for this is that the size of the USB is bigger than what you downloaded. And the media check fails because of this unavoidable discrepancy.

Without knowing the error message, it is hard to diagnose. However, it is not related to the media check “issue”.

Just as an FYI, if you want to check the sha256 on the USB this command works (modify for what you device is, mine is /dev/sdb):

dd if=/dev/sdb bs=4096 count=$(($(stat -c '%s' openSUSE-Leap-15.0-DVD-x86_64.iso) / 4096)) | sha256sum

Aslo had "This is not an opensuse 15.0 media" yesterday on usb stick created with dd (full 4.7G image). Really looks like there is a problem - it is rather uncomforting to install after seeing this message - especially when it is about wife’s computer :wink:
I am sure it is reproduceable easily by dev.

Reproduced again on other setup. Created bug :
Bug 1094970 - “Check installation media” gives “This is not an opensuse 15.0 media”
FWIW my install went fine anyway

… of course.

the “Check installation media” only works when the installer is burned to a DVD, not when it is copied to a USB stick.

… as others tried to explain here.

Well, the bug report could have asked for a better explanation then. E.g. renaming the item to “Check DVD installation media” (though I still wonder why the plural here, it does only check one DVD medium at a time I assume).

I am back just to tell the install went fine.

Indeed, a renaming of the item would be comforting


Oh, yes, indeed. I agree completely.

Just wanted to point out to the OP what we were trying to say so it was clear.