Check Installation Media -> This is not a openSUSE Tumbleweed medium. Why?

I downloaded the Tumbleweed ISO and checked the SHA hash.

$ grep -i $( openssl dgst -sha256 -r open*iso | awk '{print $1}' ) open*sha256
d36f8930de2cf2dd0566f46196cc7fbf4946b64073ab1154e2792a48b93353d2  openSUSE-Tumbleweed-DVD-x86_64-Snapshot20160417-Media.iso

I burned the ISO to a newly purchaed 32GB USB flash memory stick.

$ dd bs=$(( 4 * 2 ** 20 )) if=open*iso of=/dev/sdb

I shutdown the machine and disconnected all disks other than the flash stick. I powered on and allowed the machine to boot from the flash stick. Shortly I saw the green lightbulb logo and then the menu.

Boot from Hard Disk
More *

I moved the hilight to More and pressed Enter. I was presented another menu as follows:

Rescue System
Boot Linux System
Check Installation Media *

I moved the hilight to Check Installation Media and pressed Enter. After a short time I was confronted with a scary red text box with Ok button stating exactly the following:

> This is not a openSUSE Tumbleweed medium.

Why, and how do I correct this?

There’s nothing to correct.

The media check does not work when you use a USB. If the checksum is correct, and no errors were reported when writing to the USB flash drive, then all is probably fine.

When I first tried the media check on a USB, it told me “insert the CD or DVD to be checked, and hit ENTER”. The only other time that I tried, it reported an error.

If you write the iso to a DVD, and then check the size of the DVD (by reading it back and counting bytes), you will get exactly the size of the iso file. But when you do write to a USB, you will get the size of the USB rather than the size of what was written. I think that’s what interferes with checking.

Is there a checksum file on the image for all the files instead of the image as a whole? I think I want to try one more time with a little different command to make the stick.

If you copy the image properly no checksum is needed on a USB DVD need media check because DVDs are inherently error prone.

copy the iso as a binary to the device. NOT a partition on the device

personally I just use cp if /dev/sdb is the USB then

cp pathtoiso /dev/sdb

I don’t think so.

However, you should be able to use “cmp” to compare the USB stick to the iso.

Assume that the USB stick is “/dev/sdX” on your system. You should have written the iso directly to that device (I normally use “dd_rescue” for that, though “dd” will do.


# cmp --bytes=nnnn /dev/sdX filename.iso

where the “nnnn” is the file length of the iso file.

Note, however, that some commands might change the MBR, so best to do the “cmp” immediately after creating.

I think I have succeded in making an intact copy of the image on the flash stick. This time I am using a block size of 1, which I think will ensure that no partial writes can happen. I know this makes the copy take longer, but after quite some research I am convinced it is the only safe way to use dd.

# parted /dev/sdb print
Model: Kingston DataTraveler 3.0 (scsi)
Disk /dev/sdb: 31.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1892kB  5763kB  3871kB  primary               esp
 2      5763kB  4659MB  4653MB  primary               boot, hidden

# dd if=/dev/zero of=/dev/sdb count=100
100+0 records in
100+0 records out
51200 bytes (51 kB) copied, 0.000490528 s, 104 MB/s
# wc -c openSUSE*.iso
4658823168 openSUSE-Tumbleweed-DVD-x86_64-Snapshot20160417-Media.iso
# dd bs=1 count=4658823168 of=/dev/sdb < openSUSE*.iso
4658823168+0 records in
4658823168+0 records out
4658823168 bytes (4.7 GB) copied, 11750.3 s, 396 kB/s
# cmp --bytes=4658823168 /dev/sdb openSUSE*.iso

I still get the error when I choose *Check Installation Media

This is not a openSUSE Tumbleweed medium.


That looks good. The “cmp” command is silent when it succeeds, and gives the location of the first difference when it fails.

I still get the error when I choose Check Installation Media

Yes, that is pretty much certain to happen. The media check is not designed for use with a USB.

Hi nrickert,
good to read that clear remarks - I was just coming across the same message of the installer while installing tumbleweed …

Now this isn’t a good idea.
Because if the data is stored in blocks of e.g. 512 bytes on the USB stick/key then each block has to be flashed physically 512 times before its contents are complete - which clearly results in a lot of wear of that USB stick/key, and which will thus reduce its lifetime more than is necessary without having any benefits.

Greets to everyone here