Check configuration for pluggable authentification modules

I dared to update my openSUSE 12.1 system a while ago. One day I would like to use a root shell again like it worked before with an application like “Terminal - Super User Mode”. (I would like to run the tool “zypper” there once more.)
But I see that such a terminal window does not display the command line after I enter the appropriate password for the corresponding enquiry. The login display stays on screen and does not continue with the expected input processing. I find information like the following in the file “/var/log/messages”.

Aug  1 10:48:49 Sonne su: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-iW5LQg/control
Aug  1 10:48:49 Sonne su: gkr-pam: couldn't unlock the login keyring.
Aug  1 10:48:49 Sonne su: (to root) elfring on /dev/pts/2

Do the mentioned details from a bug report by Michal Vyskocil need a bit more attention to resolve such an open issue?

But there is no need to start a terminal session as super user. You can start a normal session and use sudo to run a command as root or use the** su -** command to become root for a series of commands then type **exit **to return as a normal user. zypper works great with the sudo command, you should give it a try. If this does not work for you then there is a problem with your openSUSE installation. Sometimes doing a openSUSE upgrade can do odd things to your installation depending on how far down you where before the upgrade. Updates should work just fine however. Can you tell from what version you upgraded, if true and/or if this was a 32 or 64 bit KDE or GNOME desktop?

Thank You,

Yes. - The other commands do also not work at the moment here because of the same error reaction.

Updates should work just fine however.

I know … - But it happens that they bring new usage challenges with their dependencies occasionally.

Can you tell from what version you upgraded, if true and/or if this was a 32 or 64 bit KDE or GNOME desktop?

I started with KDE from an openSUSE 12.1 (64 bit) installation DVD. I added some other desktop environments shortly thereafter.

In general, dependencies have nothing to do with running in terminal or not. You need to be root to install any software usable by all users (not installed into your home area). Running YaST most often is a better way to deal with such installation problems. Here is my caned info on dealing with dependency problems.

To avoid package problems, the most important thing to do is to: NEVER
ignore a dependency, even if YaST/zypper/updater gives you such an option!
In general, never switch to an >inferior< architecture and the solution is
most often to just switch Vendor to the >Packman< repository. So changing
the vendor is OK, but >ignoring< dependencies is never a very good idea!

I normally suggest starting YaST / Software / Software Management / Options / Check option: Allow Vendor change. Next I select Package / All Packages / Update if newer version available. I add only the All Of Packman as an addition repository in YaST / Software / Software Repositories.

Thank You,

I am more interested in a solution for the concrete consequences in the reported use case.

So package dependency problems was not really your original problem as you started this message thread. Give us a blow by blow dependency issue and I shall tell you what to select.

Thank You,

I guess that a few of the many software updates lead to the shown open issue.

A little statistic about installation changes:

June 2012 Package count
27 448
28 1138
29 879
30 359

I assume that a package like “gnome-keyring-pam 3.2.2-2.8” is involved in the usage difficulties.