Character encoding


I often switch between windows and linux and want to edit files, I edited under windows just before. The problem is: When I open textfiles saved by a windows based program, i can’t load it completely in linux. Some charakters like ä, ü, ö, ß etc. are not displayed an replaced by a questionmark.

Can somebody help me?


i have the same problem,one of my friends told me that there’s an extension for mathematical symbols and foreign letters but i can’t find it,or better i haven’t still understood if it exists or not.

A lot depends on the applications you are using in Windows and Linux. As I rule I find that OpenOffice correctly translates Western European accents in .doc files.

If you aren’t using .doc files, OpenOffice usually puts up a dialogue which allows you to select the encoding. So, for example, if you have .txt files from Windows, OpenOffice will usually ask you what encoding to use.

You may need to experiment with other applications.

I used just simple .txt-document.

In windows you might be using one encoding, like one of iso8859, while in Linux UTF-8.
You’ll need to change the encoding to get the right characters.

Yes, the problem seems to be, that windows uses windows-1252 codepage. I found a codepage named cp1252, that might be identical but it isn’t :confused:. Firefox uses a codepage named windows-1252 and this works well, but the linux editors (like kile, kwrite, texmaker etc.) don’t. Can I manually change the codepage?!?
Or install a new one? Or do I have to change settings within windows applications ?

Emacs uses the right encoding!! Why not kile?!?

Simple, don’t use cp-1252. Use an international standard like utf-8 or iso8859-x.

Sorry for bugging you - my stupidity :o. Obviously I saved the test file while using the wrong encoding, then I always reopened the damaged file. Everything works well.

Windows Notepad can read and save UTF-8 too. There is no excuse not to use utf-8.