changing to user with su - no sound on leap 15.4


Changing user on leap 15.0 / 15.2 with
su - <user>
the user has access to the sound device if the user is in the group audio.
On leap 15.4 this does not work anymore, there is no sound on this user, only the principal user which is login in kde with sddm.

Example error from vlc:

VLC media player Vetinari (revision 3.0.13-8-g41878ff4f2)
00005606c6a1b610] vlcpulse audio output error: PulseAudio server connection failure: Connection refused
00005606c6960d30] main libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-test1’
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

00005606c6a1b610] alsa audio output error: cannot open ALSA device “default”: Connection refused
00005606c6a1b610] main audio output error: module not functional
00007f5d6cc18350] main decoder error: failed to create audio output

Output of inxi -U;[FONT=monospace]inxi -Aa

Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.14.21-150400.24.11-default running: yes
Sound Server-2: JACK v: 1.9.12 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.49 running: yes

What’s the clue on leap 15.4 to have access to the audio device?

Is the user “pulse” in the “audio” group?


Yes user pulse is in audio.
I’ve also tried to put uses in pulse and pulse-access put still no sound…