Changing Splashy Boot Screen

hello, im trying to change the splashy boot theme to one that i created. i downloaded a picture in .jpg format and re-saved it in gimp as a .png. next i ran the command

splashy_config -c

and filled in all of the fields appropriately without errors. next i ran

splashy_config -s artgeeko

where artgeeko is the name of my theme i created. when i run

splashy_config --info

it says that my current theme is set to the artgeeko one i created but when i reboot it still uses the openSUSE theme (the default one that openSUSE ships with). im not seeing any errors on boot. does anyone know why this is not working?

EDIT: i also tried to resize the image down to 1024x768 and that did not work and i tried using one of the themes from splashy-themes (the fingerprint theme) and that did not work either.

Custom splash screen - openSUSE

so from the looks of this openSUSE doesnt use splashy as its splash screen program it uses a program called bootsplash?

i tried out these instructions with a bootsplash theme called Black_SUSE from the system still boots up with the green openSUSE theme.
i also found this post Getting Splashy To work - openSUSE Forums that says opensuse 11 (which i use) defualts to splashy but the theme section of yast2 still references the bootsplash program

I haven’t worked with it myself, but I’m fairly sure that openSUSE uses bootsplash; splashy I think is installed as a dependency of the suspend package.

Take a look at the /etc/init.d/splash script. It calls bootsplash. So if you haven’t got your alternate theme working, you probably have an error somewhere. I assume you know you must create a new initrd, as the splash image is embedded.

Once you have figured it out, be great if you could post back what you found.

You can set your default bootsplash theme in yast and then run mkinitrd

Did you have a chance looking at the SuSELinuxSupport: HowToChangeSuSEBootSplashScreens howto

Just fyi, the link in my post #3 above is a newer version of this.

The instructions at Custom splash screen - openSUSE worked out. i had accidentally put the theme inside of a folder inside of the themse directory which is why it did not work for me. after fixing that and running the mkinitrd command everything worked out fine.

Terrific :smiley: Thx for the post back; I wanted the double-check that bootsplash themes do work.


I see no mention of changing GDM login screen anywhere? Any pointers?


It’s /usr/sbin/gdmsetup

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 5:49, 2 users, load average: 0.09, 0.04, 0.01
GPU GeForce 6600 TE/6200 TE - Driver Version:

Login screen or splash screen??

In Gnome, gdmsetup does not allow you to change either. You can change the login screen in Yast, but at present there is no way to change the splash screen except by manually editing the files. You can turn the splash screen off using Gconf-Editor. Boots a little faster that way.

Gdmsetup allows you to change the login screen (does on my system?) via
the local tab, and add a new theme, change the theme settings etc.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2:34, 2 users, load average: 0.02, 0.02, 0.00
GPU GeForce 6600 TE/6200 TE - Driver Version: 173.14.12