changing printer settings in KDE, unable to authenticate due wrong window priorities

Hi there,

I just installed opensuse 13.1 an ran into a weird problem while setting up my printer. When I’m in the system settings and I click on printer settings I get asked about the root password, I enter it and can see my printer. So far is everything fine. Then I click on setup and get a window where I can change the settings I want to edit, this works too. But when I click on OK or Apply then, behind the window with the settings another window pops up. Asking again for the root password. The settings window stays open, and in the foreground, and won’t let me enter the password into the password dialog.
Any suggestions as on what to do about this, or at least how to work around this?

Greetings,

Allquantor

On 02/21/2014 12:46 PM, Allquantor pecked at the keyboard and wrote:
> Hi there,
>
> I just installed opensuse 13.1 an ran into a weird problem while setting
> up my printer. When I’m in the system settings and I click on printer
> settings I get asked about the root password, I enter it and can see my
> printer. So far is everything fine. Then I click on setup and get a
> window where I can change the settings I want to edit, this works too.
> But when I click on OK or Apply then, behind the window with the
> settings another window pops up. Asking again for the root password. The
> settings window stays open, and in the foreground, and won’t let me
> enter the password into the password dialog.
> Any suggestions as on what to do about this, or at least how to work
> around this?
>
> Greetings,
>
> Allquantor
>
>

Either minimize the ‘settings window’ or move it out of the way.

Ken

If it was that easy, i would not have to ask here. When I try to click on the “enter password”-window, the focus automatically bounces back to the settings window. I guess it’s a bug in the printer settings window or in the “enter password”-dialog.

For now I have found a workaround: If you log out of KDE and than log in as root you can change the settings because root doesn’t get asked for passwords. Even though this works it woud still be great to get it working in the right way, since loggin in as root is pretty ugly…

Greetings,

Andreas

I can reproduce the problem here, but I can’t provide you a workaround.

This is definitely a bug in the printer settings module, looks like this:
https://bugs.kde.org/show_bug.cgi?id=328014
To not having to login as root, run systemsettings as root:

kdesu systemsettings

Or even better, just run the printer configuration module as root:

kdesu kcmshell4 kcm_printer_manager