Changing permission from root back to user - chown?

I just installed Leap on my system. I was running Kubuntu previously. I have multiple partitions, and all but two of them are formatted with the ext4 file system. Two of the partitions are formatted NTFS, and the user is root, and group is users. Because of that I can’t write to any of the root owned partitions.

I know I’m supposed to change the permissions using chown, but I can’t figure out the exact syntax to make it work. How do you do an entire drive?

I run KDE, so I’ve tried in Super User Dolphin to change it, but it won’t work.

Any easier way to do it via Yast or something? thanks!

Incidentally, the other drives have “scott” for user, and “1000” for the group.

You cannot do that with “chown”. That’s because NTFS does not support the linux/unix permissions.

Here’s an entry from my “/etc/fstab”:

/dev/disk/by-id/ata-WDC_WD10EZEX-75ZF5A0_WD-WCC1S1730155-part5 /windows/C           ntfs-3g    noauto,users,uid=1001,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

The “uid=1001” makes me the owner (my uid is 1001 when I login normally. Depending on whether you want other people to be able to write, you might also need to change the “fmask” and “dmask”.

You will note that I have “noauto” there. That’s because I don’t want this file system automatically mounted at boot. I manually mount it when I have a special need for that. That’s by way of explanation. I don’t know what options are appropriate for you.

What it all amounts to, is that unix style file permissions are simulated for NTFS file systems, and the mount options specify the details.

(Note: that’s one line in the code box. It somehow got wrapped on pasting).

That did it! I added “uid=scott” to that line in fstab and now I can write to both partitions. Thanks again…

I use a different approach for ntfs partitions, I don’t edit fstab, but I use polkit
basicly I create a file by executing

kdesu kate /etc/polkit-1/rules.d/10-udisks2.rules

and pasting this content

// See the polkit(8) man page for more information
// about configuring polkit.

// Allow udisks2 to mount devices without authentication
// for users in the “storage” group.
polkit.addRule(function(action, subject) {
if (( == “org.freedesktop.udisks2.filesystem-mount-system” || == “org.freedesktop.udisks2.filesystem-mount”) &&
subject.isInGroup(“storage”)) {
return polkit.Result.YES;

I use a new group storage for security reasons, you can use the generic users group, I’ve added myself to the storage group so no other users can write to ntfs partitions without root privileges, now I can mount an ntfs partition with any file manager without the need for a root password.
and if I change the disk partition structure I don’t have to edit /etc/fstab as I have 3 hard disks and 2 of those have a couple of ntfs partitions, editing /etc/fstab limits me to known drive addresses, using polkit does not have that limit.