changing monitor type = big trouble

Hi all,

I just installed myself openSUSE, after hearing lots of good things.
Now, after installation I went on configuring everything.
I noticed my monitor was not being recognised. So I looked in the list, but it wasn’t there. so I chose another model with about the same specs.
after reboot, I logged on and it hangs on the green screen.
I went looking for some things and I found booting to logon, switch to console as root and running sax2 -r -m 0=vesa
that doesn’t solve it, but restarting gdm after that does :slight_smile:
now, every, really every time my pc boots i have to go through this to get logged on in gnome.
Also, on 24 hours time my machine froze up twice while no action was taken at the time.

Has anyone got some suggestions as to finding the problem?

thanks in advance,

Just tried to log in to gnome with failsafe options, same result.

After a lot of looking around i found the system log and the last entry at the times of the freezes, it says:
kernel: REISERFS warning (device dm-0): vs-13075 reiserfs_read_locked_inode: dead inode read from disk [2 232 0x 0 SD]. This is likely to be race with knfsd. Ignore

so I’m thinking it has something to do with the filesystem?