Changing boot resolution on a PPC Apple G3 system

I have 11.1 installed on an old G3 system. The PowerPC config has worked well, but after an update I get a black screen at GDM. I think all is well, but the resolution/refresh rate is set too high.
How can I get in to change to runlevel, access SAX2 or change the GDM/Gnome resolution settings?
I think I’ve been able to blindly login, and the Gnome resolution is the same–no help.
Thanks for any help!

  1. Login as root

  2. Issue the command ‘telinit 3’ - all level 5 processes will then shut down.

  3. Press Enter to get back to the prompt.

  4. Navigate to ‘/etc/X11’ and ‘more xorg.conf’. Note the value of ‘Driver’ under the ‘Device’ section.

  5. Sax is run with the command ‘sax2’. If you want to setup the ‘xorg.conf’ again then, take a copy ‘cp xorg.conf xorg.conf.xxx’ and do

sax2 -r -m 0=<name of driver from 4)>
.

  1. If it all goes well, reboot.

If that doesn’t work and you are in a worse situation than before then copy back xorg.conf and we can think again. A temporary solution is to use ‘vesa’ as the driver name at step 5).

Note you can start the system at runlevel 3 by typing the character ‘3’ at the Grub menu and pressing Enter.

HTH

Thanks, I need those commands.
But first I just need to get to the terminal and see it!
I don’t get any visual once GDM boots because it has too high resolution, and then Gnome follows suite…
It’s not GRUM or LILO I’m running because it’s PowerPC, I can’t remember what it’s called, but I’m not sure how to offer custom boot commands to allow me to get those changes in.

The PPC loader is called yaboot. I never quite figured out how to pass kernel arguments to it. I tried a few idioms from GRUB but they didn’t work. And the tips from search results are sometimes contradictory. Maybe when I’m desperate I will learn how.

However you could try switching to a different console with Alt-F2 (F1 is used by the login manager), and then login as root and edit the yaboot config file.

If even more desperate you could boot with a PPC Linux CD (I used Ubuntu, even though the machine has Fedora installed), mount the boot filesystem and edit the yaboot config file. I did this when I had forgotten the root password (it was a machine I had not powered up for a while).