Changing audio devices does not save upon shutdown

I can’t view that image. (We generally prefer users post to https://paste.opensuse.org/ instead.)

Anyway, show available sinks and sources…

pactl list sinks | grep "Name:"
pactl list sources |grep "Name:"

Perhaps show the default.pa content as well.

Check also /etc/pulse/client.conf

You can use yast2 to set your audio device default, not sure now I haven’t use that in a while.
If you are using xfce you might as well save the session and startup under xfce4-system-settings
after configuring your devices.

Quoting my own post.
Correction, I am referring to saving in Settings Manager-Session and Startup-Current-Session
Click the Save Session.

Another thing comes to mind:)
Open audio mixer(pavucontrol) Under configuration, turn off or disable the audio device you don’t want to use.
If you are using pulseaudio and not pipewire you can install paprefs, this way if all didn’t work
enable the simultaneous sound, this will make all devices work simultaneously and you are not going to have a problem
because both devices just work it’s just a matter of turning off the the attached speakers which you don’t want to use.