Changing audio devices does not save upon shutdown

Every time I shutdown or restart my computer, the audio devices I have set for input and output do not save, it always reverts back to the defaults. This is really annoying as I do not want to mess with my device configuration every time my computer starts up. I have already tried to update my system and everything seems to be up to date. What can I do about this?

At least explain what you did to change the audio configuration.

Always assume that there are several ways to do things on Unix/Linux and that others do not autmagicaly know which way you walked.

Which Desktop GUI are you using?

  • Some Desktops allow you to choose (and implicitly save) which devices shall be used as the standard input or output audio device – such as the one I use – KDE Plasma …
  • AFAICS, other Desktops do not offer this facility – or, maybe, only by means of a tool which has to be either installed or activated …

I changed the config using the normal graphical tool. I understand there are other ways to change it but every graphical tool that I’ve used up until this point has supported saving changes in audio profiles implicitly. I cannot for the life of me find any way to save these changes in a meaningful way and it *should *just work but it does not, even after applying updates. I am so lost as to how any of this is supposed to work

Edit: There should also be the Leap 15.3 tag on this post, no idea why it’s not there. I’m using Leap 15.3

Also I double posted because I wanted to delete the original post (this one) as it seemed to be in the wrong channel, but I could not find any way to do so. Is it possible to delete my own forum threads?

I guess your real question is if we can move this to applications. I will do that. Next time you can ask by using the report button (! in triangle) below a post (or post in the most fitting forums from the begin).

I am afraid that “the normal graphical tool” is not really telling us what you used. Is it so difficult to tell? And the prefix 15.3 is there. At least I see it.

I think it’s pulseAudio but the name for the window is just “volume control”. I have no idea what the actual name of the audio interface is because that’s the only name for it that I can find anywhere on any of its windows

Edit: Also, I’m using the XFCE version of Leap, forgot to mention that as well

Yes, the mentioning that you use XFCE as DE is rather crucial. Other XFCE users could have guessed then what you used. My suggestion, next time you start a thread, put that XFCE in the title to draw the attention of XFCE users that may browse through the titles of new threads.

And there is of course always YaST > Hardware > Sound, the GUI on the system level.

This item fails to work rather often. Developers describe it as outdated.

That does not matter as we are trying to find out what “the normal graphics tool” is. I am only informing the OP that there are more of them. Not about their qualities.

Regardless, checking that window was of no use to me to solve this issue, because the device I wanted to be the default output was not listed. I know for a fact now it’s pulseAudio, however even modifying Pulse’s config files like this suggests: https://wiki.archlinux.org/title/PulseAudio/Examples is not doing anything for me

I’ve been trying everything that I can to set default devices through PulseAudio’s tools, including in the terminal with guidance from here: https://askubuntu.com/questions/294512/setting-the-default-alsa-device-for-pulseaudio and using ‘pacmd set-default-sink’ has not been helping at all. I’m starting to suspect PulseAudio is entirely responsible for this issue and no amount of direct tweaking seems to be helping here. I’m at a loss as for where to go from here

What does the following report?

pactl info

Persistent changes (for a given user) can made by creating/editing ~/.config/pulse/default.pa as required.

https://wiki.archlinux.org/title/PulseAudio#Configuration_command

So upon startup, pactl info says:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 8
Tile Size: 65472
User Name: PlusNine
Host Name: PlusNineDesktop
Server Name: pulseaudio
Server Version: 14.2-rebootstrapped
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_28_00.3.analog-stereo
Default Source: alsa_output.pci-0000_28_00.3.analog-stereo.monitor
Cookie: a7c9:4b71

and then when I change the devices via the pulseAudio GUI, it reports this:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 34
Server Protocol Version: 34
Is Local: yes
Client Index: 11
Tile Size: 65472
User Name: PlusNine
Host Name: PlusNineDesktop
Server Name: pulseaudio
Server Version: 14.2-rebootstrapped
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.usb-Kingston_HyperX_Cloud_Alpha_S_000000000001-00.analog-stereo
Default Source: alsa_input.usb-C-Media_Electronics_Inc._JLAB_TALK_PRO_MICROPHONE-00.analog-stereo
Cookie: 02ea:68a4

With the default sink and default source reporting the devices I changed them too

Create/edit ~/.config/default.pa, adding the following entries…

set-default-sink alsa_output.usb-Kingston_HyperX_Cloud_Alpha_S_000000000001-00.analog-stereo
set-default-source alsa_input.usb-C-Media_Electronics_Inc._JLAB_TALK_PRO_MICROPHONE-00.analog-stereo
  • For setting system-wide default you edit /etc/pulse/default.pa

Referfences:
https://wiki.archlinux.org/title/PulseAudio/Examples#Creating_user_configuration_files
https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/DefaultDevice/

So I gave this a try and still no luck. PulseAudio still assigns the original default sink and source even after it finds the devices I want to be the defaults

Strange…perhaps the desktop environment (audio compnonent) is having an effect (at login) here?

FWIW, another similar thread here…
https://forums.opensuse.org/showthread.php/543265-Pulseaudio-default-output-problem/page2

Sorry, that should have been ~/.config/pulse/default.pa

So when I made this change and restarted my computer, this: https://imgur.com/a/WXZfMEq happened and didn’t stop for 2 minutes so I assume that adding this file broke PulseAudio. This solution also looks like a non-starter unfortunately