Changes of max remote sessions without effect in gdmsetup


maybe someone can help :slight_smile:
On a server hardware with openSuSE 11 runs gdm as the default display manager, gnome ist first choice; optional the user can choose kde3. Remote sessions should be available in a LAN, and up to here the system works nearly fine.

Now I tried to change the “maximum number of remote sessions” in the “XDMCP Settings” of “gdmsetup” from the default value of 16 to 32. But changing the value have no effect. Still “only” 16 remote desktops are availible. XDMCP explain the xwin32-Client of the 17th User: Max. number of sessions reached!

Strange to me: I see the changes I’ve made with gdmsetup in the [XDMCP]-Section of /etc/gdm/custom.conf and

gdmflexiserver --command="GET_CONFIG xdmcp/MaxSessions"

answers with the new value of 32.

The same happens when changing the value of “DisplaysPerHost” (which makes testing easier:) ).

Does anyone out there has an idea, where I goes wrong? Why do my changes have no effect?



Have you restarted xdm?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 18:28, 2 users, load average: 0.03, 0.02, 0.00
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I also see there is a gdm-restart command, have you tried this too?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 18:35, 1 user, load average: 1.40, 0.52, 0.18
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80


Restarting gdm/xdm doesnt have any effect.

Still puzzled…


to whom it may concern:

after getting a hint from an admin I searched the gdm changes and found at:

2008-05-03 Brian Cameron <>

  • daemon/gdm-xdmcp-manager.c: Move reading of configuration
    from gdm_xdmcp_manager_init to gdm_xdmcp_manager_start
    Otherwise the configuration values get over-ridden by the
    deafult values set via properties. Fixes bug #515148.

This is exactly what I read in the DEBUG messages on my system.
I could’nt find a patch to eliminate this behaviour. I there an option to contact SuSE for creating such a patch?



hello again,

I must be blind… :slight_smile:
I’ve found the bugzilla link to Novell and this bug reported a few moments ago:

So, this thread could be closed :wink: