Changed the baseurl of security tools repository

Hello,

We have been using security tools repository over multiple regions in AWS.
Suddenly, zypper has started to fail in ap-southeast-2 region with the following error:
OS: SUSE Linux Enterprise Server 12 SP5

10:31:55 AM Customer: Repository 'SLE-Module-Web-Scripting12-Updates' is up to date.
Retrieving repository 'security-tools' metadata ------------------------------------------------[|]
Download (curl) error for 'https://download.opensuse.org/repositories/security/SLE_12_SP5/repodata/28f69b1324bd29f249dbdc74613dd76dbf82527b8c745dc109e3df49ec07457c-primary.xml.gz ':
Error code: Curl error 35
Error message: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

The AWS support recommendation was to change the repository download.opensuse.org to opensuse.mirror.liquidtelecom.com. Unfortunately this would cause us to rework our pipelines to support different SUSE regions.

Does anyone have an idea what caused this issue only for ap-southeast-2 region and is there another way to fix this?

This here are the openSUSE forums, not the SLES/SLED forums.

Better go to the correct place.

1 Like