Change theme in 11.3

I’ve tried openSUSE 11.2 live and I’ve appreciated very much the default theme.
In 11.2 you can change theme by right-click on wallpaper->Dekstop Settings->theme.

In 11.3 there’s no more that “Desktop Settings” voice from right-click’s menu, there’s only a “Desktop Activity Settings” which only let me choose wallpaper.

I’ve saved from live cd icons, themes and wallpapers of 11.2 and now I want them all in 11.3 as I don’t like its default theme.

You can change the wallpaper via right click
Themes via System Settings > Workspace Appearance


And what about import the entire theme??

I hope the only solution to have 11.2-look is not to install 11.2 and then upgrade…

I’ll have to look at this later

Name the themes for when I return

Theme “Air openSUSE”

It’s what is displayed on 11.2 live, by looking in right-click on wallpaper->Desktop Settings

Do you mean this](

I mean that place but this theme](

It seems they’ve update theme too, what i’ve to do?
Save the theme from live 11.2 with a name different from “Air openSUSE” and then add it from 11.3 or what?

The theme looks the same, but I expect the wallpaper is different
You can put any wallpaper up you like

I don’t need a wallpaper, the theme looks different in 3 things, 2 important 1 not:



  1. the buttons in 11.3 are, for me, ugly, I want the old window border, but I haven’t find anything like the Gnome’s theme customization.

  2. the font for menus in 11.3 are less readable, if you look at the 2 picture, you’ll see that in 11.3 the various File, Modifica, Visualizza and so on are smaller and less definied.

  3. I use openSUSE on a notebook, so I always use the power button to suspend/shutdown, so the 2 button on bottom right are too big; in 11.2 they were really small and put one on the top of other and they weren’t annoying.

  4. and 2) are the most important, as for 3) i could simply remove them.

That screenshot shows Firefox. Firefox is a XUL application, but it uses GTK settings. So “GTK Styles and Fonts” is where you have to look if you wish to select better fonts for Firefox’ menus etc. “GTK Styles and Fonts” can be found in Personal Settings>Application Appearance, or you can directly open it via ‘kcmshell4 kcmgtk4’.

If you select “Use my KDE fonts in GTK application” it will use the same font for GTK applications as you have selected in “Personal Settings>Application Appearance>Fonts” (or ‘kcmshell4 fonts’) as “General.” The selections that you make for Menus, Toolsbars and so on have no bearing on what fonts are selected for GTK applications and only apply to Qt applications.

I have to correct myself. It is only Firefox (et al) that use the General font throughout. Proper GTK applications use the font you select as Menu font for menus, Toolbar-font for toolbars etc.

It’s not only Firefox, it’s even Dolphin, documents, pictures, everything.
I think that window border are independant from qt/gtk: if I install k3b on Gnome, the program will use Gnome’s window border.

And in Application Appearance for GTK “Use my KDE fonts in GTK application” was already enabled.

That is correct. I cannot help you with the window borders though, since I use QtCurve for everything and it has been quite some time since I have seen the default Oxygen window decoration.

Then I guess you need to make sure that you have selected exactly the same fonts, with exactly the same settings for size, dpi, anti-aliasing and on. From the screenshots, it seems to me that the fonts for the menus were 1 or 2 points larger in 11.2 than in 11.3. For the window title you used a bold font in 11.2 whereas in 11.3 it is a regular one.