Change the OEM Logo on boot


I just updated all my systems to Leap 15.2 and saw the new boot animation displaying the OEMs logo on boot.
But on my Thinkpad t420s, there is no logo, just the spinning animation and the Leap logo.
Is there a way to put a custom image into the boot screen, so I can fix this?

Thank you very much


What boot method is used on both systems - legacy BIOS or UEFI?

I think there’s a way of changing the plymouth theme, It is configured in “/etc/plymouth/plymouthd.conf”. But I don’t know where the themes are stored or what other choices are available.

Showing the OEM logo is a new thing and the image comes from the BIOS. Probably some differences in the EFI/BIOS code

Likely see the OEM logo with secure boot disabled.

You might need to clarify,
There are two times a splash screen will be displayed and each are handled differently

  • Prior to the Grub menu
  • After the Grub menu

And although you don’t seem to be asking about it, some people may be interested in modifying the background and layout of the Grub menu itself.