Change Font size in Dolphin

I want to convert my dumb TV into a smart TV without all the disadvantages (reporting back to Google, Facebook, Amazon, etc…) so I installed a little fanless minicomputer with Leap 15.1 and connected it to the TV’s HDMI port. Everything works well except from the distance I watch TV I cannot read what is shown in Dolphin. So I thought it is a simple matter to increase the font size. so I tried:
Dolphin > Settings > Configure Dolphin > View Modes
Go to Label Font and select Custom Font
Go to Choose… and select Font Size 18 and click OK and Apply
Now the only change is that the label “Custom Font” on the button is larger. All the other fonts (on buttons as well as on Dolphin proper) are still as small as before.
nothing changes. When I close and reopen Dolphin again nothing has changed.
That must be a software fault because nobody wants to change the font on a singel button and nowhere else. Further configuration changes should not disappear when you close Dolphin.
The slider on the bottom only increases the icon size.
Is there a way to increase the font size in Dolphin at all?

Did you try restarting plasma after making the changes?
for me - the steps you describe above change the font size in dophin (in Tumbleweed with plasma 5.19)
Perhaps you could try Tumbleweed or even 15.2 beta that both have newer versions of plasma

Thanks for your reply, farcusnz, but even after restarting the desktop (logout - login) the font size is small and back to 10 even though I had changed it to 20 before. I will try it in Tumbleweed on my laptop but the computer for the TV should not run tumbleweed. But to me this looks like a software fault which hopefully is fixed in the new version when Leap15.2 comes out.

On my tumbleweed laptop (version 20200618) with plasma desktop 5.19.0-1.1 I cannot change the fonts either.

Yes, you’re at the right place in the configuration but, within “View Modes”, there seems to be an undocumented behaviour:

  • If the setting is to be permanent, for each of “Icons
    ”, “Compact” and “Details”, the “Label Font” setting has to be changed from “System Font” to “User Defined”. - It also seem to help to change Dolphin’s view mode while changing the setting for the concerned view mode …

BTW: Dolphin Handbook – “View Modes”: <https://docs.kde.org/stable5/en/applications/dolphin/configuring-dolphin.html#preferences-dialog-viewmodes&gt;.

I’m following your instructihttps://paste.opensuse.org/view/simple/18582532ons exactly. Not sure why it isn’t working for you (especially in tumbleweed - I’m running 20200620)
https://paste.opensuse.org/view/raw/18582532
https://paste.opensuse.org/view/raw/10942517

You mentioned in the opening post that, you “OKed” and applied the settings changes.

  • Did you check that, the font in the Dolphin window changed?

[HR][/HR]What I’ve noticed is, that within the settings window, when the font settings is revisited, the settings are the system wide ones …

  • Which is a little bit annoying because, one expects the current custom settings to be displayed …

[HR][/HR]Which custom fonts are you using?

  • I’m using Bitstream Vera Sans but, I suspect that standard KDE Plasma fonts will also be OK.

Thank you, dcurtisfra, the problem is now solved. Yes the problem was that when you open the settings window it shows the default settings and not your actual settings. In my case I always select the Detailed Vew mode but when reopening the setting window (Vew Mode) shows the default Icon View mode. I assumed the font settings below apply to all modes but they only apply to the view mode which is selected above - no matter what view is selected. So reselecting the detailed view mode (which I have anyway) and then selecting custom and font size changed the font size in my view mode.

BTW I didn’t change the font itself, I only selected the Custum Font setting to activate the font window which has the font size included.

So thanks again dcurtisfra and farcusnz for your help.