Change Folder permissions

On my dual-boot system, 11.4 and win7, I wiped out the Doc and DL folders in my home directory and replaced 'em with links to the ones on the windows side. It works great except for one thing: When I open Dolphin in superuser mode and change the permissions to make myself the owner of those folders, the change doesn’t take. Is there a special trick to it?

GEF

PS: I plan to use openSUSE as my main OS, but it’s easier to keep my data on the NTFS partition, because Linux speaks Windows better than than Windows speaks Linux. Besides, that’s where my data already lives.

PPS: Do I need to change permissions from within Windows, since these folders live on an ntfs partition?

Windows file systems don’t have the same concept of ownership. The ownership shown for Windows files is virtual.

If you are the only user of the computer, then you can modify the mount parameter is “/etc/fstab”, so that the files are treated as owned by you.

Here’s the entry for my Vista partition:


/dev/disk/by-id/ata-WDC_WD3200AAKS-75SBA0_WD-WCAPZ2050503-part3 /windows/C           ntfs-3g    ro,user,noauto,users,uid=601,gid=users,umask=0002,nls=utf8 0 0

That won’t work for you as given. For example, I have it default to a read-only mount. However, note the “uid=601” part of that line. It makes me the owner of everything on that partition. I think you can have a user login name there rather than a numeric ID.

Thanks, nrickert, I am the only user of my laptop, so this looks like the right direction. In Yast, I looked up users and determined that my numeric id is 1000, then I went into the partitioner to edit fstab options, added “uid=1000” between “users” and “gid=users” just as in your example, applied changes and got an error, tried proceeding anyway. Nothing broke, bur I’m still not the owner of the partition. -GEF

Here’s the relevant line of my fstab:

/dev/disk/by-id/ata-Hitachi_HTS725050A9A364_100520PCK404VLHW0N8J-part2 /C ntfs-3g users,uid=gef,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0

I also tried it with uid=1000 as indicated in previous post, but I still can’t open my documents except as read only or otherwise create or modify content on the C partition except in superuser mode. Are there any other codes from your example that I should add, or codes here that I should remove?

Thanks again,

GEF

On 07/25/2011 08:16 AM, gfagan wrote:
>
> I’m still not the owner of the partition.

no matter what you do you can not change the permissions on a NTFS
partition to show you as the “owner” of any directory/folder on that
partition…because (as @nrickert already stated) “Windows file systems
don’t have the same concept of ownership.” and no winFileSystem (that
i’m aware of) has the ability to store the Linux ownership bit…

while it is possible to read/write from Linux to NTFS i try to
discourage it…because of things like you are experiencing…

in my mind it is ok to read from NTFS but don’t write to it any
download or document intended for use on or in the Linux system…

keep your Linux stuff on the Linux side, but if you wanna listen to
music downloaded in Windows, go ahead…

ask around…


DD Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

DenverD, you raise a good point: I didn’t state my goal clearly. What I want is to be able to edit my documents regardless of which OS I’m in, say with MS Office while in Windows or Libre Office in Linux, without diverging copies. If you discourage a common download folder, I’ll follow your advice. Thanks, GEF

Found a thread which recommended setting arbitrary option values to default. It worked; now I can edit my documents:

How to get full control of Win 7 Files (dual boot) in Suse 11.3 KDE

On 07/25/2011 09:36 AM, gfagan wrote:

> What I
> want is to be able to edit my documents regardless of which OS I’m in,
> say with MS Office while in Windows or Libre Office in Linux, without
> diverging copies. If you discourage a common download folder, I’ll
> follow your advice. Thanks,

welcome…

while it would be very convenient for the world to have a fully shared
document available as you describe, i think you would sooner or later
run into the little details which make MS Office and LibreOffice not the
best of friends…

that is, i think you will probably find that divergence is a given
because (as far as i know) MS Office can not save to LibreOffice format
and . . .

not to mention that MS can neither read nor write to Linux
partitions…and, the opposite is only possible after years of Linux
developers working hard to make it happen…and, any day the good folks
in Redmond could silently change the specifications such that it would
no longer be possible to read/write either direction…


DD Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

On Mon, 25 Jul 2011 15:11:42 +0530, DenverD
<DenverD@no-mx.forums.opensuse.org> wrote:

> On 07/25/2011 09:36 AM, gfagan wrote:
>
>> What I
>> want is to be able to edit my documents regardless of which OS I’m in,
>> say with MS Office while in Windows or Libre Office in Linux, without
>> diverging copies. If you discourage a common download folder, I’ll
>> follow your advice. Thanks,
>
> welcome…
>
> while it would be very convenient for the world to have a fully shared
> document available as you describe, i think you would sooner or later
> run into the little details which make MS Office and LibreOffice not the
> best of friends…
>
> that is, i think you will probably find that divergence is a given
> because (as far as i know) MS Office can not save to LibreOffice format
> and . . .
>
> not to mention that MS can neither read nor write to Linux
> partitions…and, the opposite is only possible after years of Linux
> developers working hard to make it happen…and, any day the good folks
> in Redmond could silently change the specifications such that it would
> no longer be possible to read/write either direction…
>

if you mostly don’t need the fancier options of M$office or LibreOffice
you could save your docs as .rtf files, which should remain readable for
both office suits.


phani.

On Mon, 25 Jul 2011 06:46:02 +0000, gfagan wrote:

> I also tried it with uid=1000 as indicated in previous post

Is that uid the uid of your logged-in user?

What is the output of the ‘mount’ command on your system?

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

>if you mostly don’t need the fancier options of M$office or LibreOffice
you could save your docs as .rtf files, which should remain readable for
both office suits.

I use .doc format and go between ms & openoffice routinely. I use plenty of advanced features which is why I don’t are for the cloud-based services; they blow away my formatting. The only issue I have is that the hyphenation dictionaries aren’t the same, which can lead to a paragraph being a line longer here or there, so I have to be careful to use “keep with next” for things I don’t want to have split across a page break.

GEF

Hi Jim,

>> I also tried it with uid=1000 as indicated in previous post
>Is that uid the uid of your logged-in user?

That is the uid I see when I click on “User and Group Management” in Yast.

>What is the output of the ‘mount’ command on your system?

Bear in mind this is after deleting fstab options on C:

devtmpfs on /dev type devtmpfs (rw,relatime,size=1857480k,nr_inodes=464370,mode=755)
tmpfs on /dev/shm type tmpfs (rw,relatime)
devpts on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda6 on / type ext4 (rw,relatime,user_xattr,acl,barrier=1,data=ordered)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda2 on /C type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
securityfs on /sys/kernel/security type securityfs (rw,relatime)
none on /proc/fs/vmblock/mountPoint type vmblock (rw,relatime)
gvfs-fuse-daemon on /home/gef/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=1000,group_id=100)

Is it possible to mount C in locked down mode generally, but separately mount one folder therein with no protection?

On Tue, 26 Jul 2011 00:56:03 +0000, gfagan wrote:

> /sys/fs/fuse/connections type fusectl (rw,relatime) /dev/sda2 on /C type
> fuseblk

This tells me that the option to use a specific uid isn’t set up properly in your fstab file.

Here’s the corresponding line from ‘mount’ on my system:

/dev/sda1 on /windows/C type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

(As you can see, I’m using uid 0 = root for this mount, which was the default configuration)

> Is it possible to mount C in locked down mode generally, but separately
> mount one folder therein with no protection?

Not really - you’re looking to apply *nix filesystem rights to an NTFS volume, and they don’t map.

Jim

Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C