Change Default Session from gnome to gnome-fallback

Does anyone knows how to do this for all users with one command?
Or which file i have to edit to do this?

Regards, Ryan.

I wrote a script which doses that - among other things:

compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI)

To switch from gnome to gnome-fallback, just type the following and restart Gnome:

compositor

To switch from gnome-fallback to gnome: Just type:

compositor gnome3

If you type

compositor

while in gnome-fallback, it switches compositing on/off.

This script in also included in the package conkyconf, available in my repo (has little to do with conky though): Easy configuring conky with conkyconf.

isn’t there an command in opensuse that can do this? for the whole system?

Hi
Under System Settings -> Graphics Forced Fallback Mode on, or;


gsettings set org.gnome.desktop.session session-name gnome-fallback


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
up 6 days 17:38, 5 users, load average: 0.16, 0.13, 0.27
GPU GeForce 8600 GTS Silent - Driver Version: 280.13

Yes, the command I use in the script. Otherwise, you can click on System Info → Graphics → Forced Fallback mode: ON … if you can find it.

but this only changes it for one user. can it be changed on the whole system?

i think there is a file in /etc/ or something that contains the default gnome session, which i’am able to edit?

You can try to edit /usr/share/xsessions/gnome.desktop (or whatever this file is called, as I’m not using the default sessions) and use the following values for Exec and TryExec in this file:

Exec=gnome-session --session=gnome-fallback
TryExec=gnome-session --session=gnome-fallback

Please report if it works.

No,this just removes the Gnome option from the login screen.
But i really like this type of idea.

If you disable 3D rendering, you won’t be able to use gnome-shell (but you won’t be able to do some other things as well).
Adding this to /etc/X11/xorg.conf did the trick on Fedora (I don’t have Gnome3 on openSUSE yet):

Section "Module"
Disable "glx"
EndSection

If that doesn’t work, another even worse hack would be to rename /usr/lib64/xorg/modules/extensions/libglx.so (or /usr/lib/xorg/modules/extensions/libglx.so) on 32bit systems. But really, the cleanest and fastest way to switch from gnome to gnome-fallback (and vice-versa) is probably to use compositor at a user level. I needed to do so and this is one of the reason why I wrote this script (that I’m going to update pretty soon btw). It’s not a big deal for users to type “compositor” once.

Gnome3 is not fun because it now uses a binary config file - simply unacceptable IMO under Linux or Unix. My guess is that the kids who developed Gnome3 must have learned to programm under WIndows. I might miss the point but I can’t see any good reason not to use a configuration which is readable an parsable with basic Unix tools. If you have to set up Gnome3 in fallback mode for hundreds of users, you can try to set it up once and copy ~/.config/dfconf/user to /etc/skel/.config/dconf/user. so that each new user you create would default to gnome-fallback (I haven’t tried though but I have this file in my skeleton for other settings than gnome-fallback). Another possibility is to use this command in one of the X startup scripts, executed by the user (not root), such as the Xsession script:

gsettings set org.gnome.desktop.session session-name gnome-fallback

I’m surprised that the --session option didn’t work.

I have an solution already. But you are right. I really liked the xml files in /etc/gconf/gconf.xml.defaults
That was / is for non gnome-shell configurations an good high customizable solution.

But really thanks for everything.